WordPress.org

Forums

Anti-spam
[resolved] Valid comments blocked (9 posts)

  1. ChristianSDC
    Member
    Posted 1 year ago #

    Thank you for this great, useful plugin. It seems like a real smart blocking process.

    I have installed ce plugin and asked to receive the detected spams by mail just to check if it worked ok for me.

    But I received a few "real" comments from "real" users which had been blocked (in addition to many spams, of course !).

    These "real" comments always had the error described as follows :
    Error: empty answer. []

    How can I fix that ? I can't use the plugin if it blocks real users now and again.

    Thanks.
    Christian

    http://wordpress.org/extend/plugins/anti-spam/

  2. webvitaly
    Member
    Plugin Author

    Posted 1 year ago #

    Please submit a link to the site where this happens.

  3. ChristianSDC
    Member
    Posted 1 year ago #

  4. webvitaly
    Member
    Plugin Author

    Posted 1 year ago #

    Error: empty answer. []

    This error is generated by Anti-spam plugin.

    Could you specify in which browsers the error occurs?

    As I can see Anti-spam plugins works correct on client (in browser) on your site.

    But some other plugin on your site blocked my IP and did not let me to publish comment:

    Access has been blocked.
    Your IP [xx.xx.xx.xx] is found at Stop Forum Spam .
    If you feel this is incorrect please contact them.
    Protected by: AVH First Defense Against Spam

    I think that this "AVH First Defense Against Spam" plugin will block some real comments in future too.

  5. ChristianSDC
    Member
    Posted 1 year ago #

    I just deactivated "AVH First Defense Against Spam" : would you be kind enough to test it again ?

    (If you do, you have to confirm your email adress : a confirmation email will be send to your adress)

  6. ChristianSDC
    Member
    Posted 1 year ago #

    I can see that your comment worked - passed the Anti-spam - but does that mean the plugin worked and won't stop ANY valid comments ?
    (I deleted your comment on the site :-) )

  7. webvitaly
    Member
    Plugin Author

    Posted 1 year ago #

    I submitted comment and confirmed email.

    As I can see Anti-spam plugin pass real comments correctly.

    If you will have more details about problems of submitting comments please post that info here and I will take a look.

    Please, delete test comment.

  8. webvitaly
    Member
    Plugin Author

    Posted 1 year ago #

    but does that mean the plugin worked and won't stop ANY valid comments ?

    It should pass real comments in future.

    But as you know there are always many unpredicted additional factors which could cause blocking comments.

    But I don't see problems on your site at the moment and everything looks fine. I don't know what caused blocking prev comments.

    If you will have more details about problems of submitting comments please post that info here and I will take a look.

  9. ChristianSDC
    Member
    Posted 1 year ago #

    Thank you for your fast help !

    I don't know what caused the problem but the same user (with same IP & everything) posted twice without getting blocked these past few hours (before I even removed AVH First Defense), so maybe it was just this once...

    Thanks again for this brilliant plugin : no spam passed the Anti-spam since I installed it 8 or so hours ago (28 comments blocked !).

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Anti-spam
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags