• Resolved robscott

    (@robscott)


    Updated to version 8.4.2 in a development site I’m working on for a client and this whitescreened the site. Will confirm error when I check the logs – but posting to help find resolution.

    Was error 504, and deleting the plugin resolved. Plugin will not reactivate – times out. Checking logs in a short while.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Support shareaholic_tucker

    (@tuckerrosebrock)

    @robscott Hi Rob! So sorry for the trouble here, and thanks for the feedback! We’ll see if we can get this resolved for you.

    Would you mind letting me know what WordPress caching plugins (if any) you’re using on your site? That’ll be a huge help 🙂 Thanks!

    Yeah its the staging site on siteground, and the siteground cacher is the error which caused server go away.

    Plugin Author shareaholic

    (@shareaholic)

    Hey @robscott a quick update – we’re working with the team at SG to figure this out. Expect a hotfix (Shareaholic v8.4.3) shortly.

    okay – I suspected this was an immediate incompatibility! Good luck.

    Plugin Author shareaholic

    (@shareaholic)

    Hey @robscott can you try updating to the latest version? please let us know if that works!

    Hi,

    I’m sorry to say that it does not. Initial upgrade made error (which pointed to Siteground optimizer), now still timing out after upgrade, even with all other plugins deactivated and on Twenty Seventeen theme.

    I’m wondering if the failed upgrade left some issue? Will try remove and reinstall too.

    Looks like the initial error, which was borking things, is gone, but then again, if the plugin never installs, we don’t know! Will try to see what I can see on this one. Your original error may well be gone.

    Actually plugin won’t delete from WP Admin, so there’s something else happening entirely…

    So I can confirm that Version 8.4.3 works with the SG Optimizer. In this case, deleting the plugin and reinstalling after the failed update did not work. What I needed to do was take out the entries in wp_options (I expect it was shareaholic_settings which was causing our issue) and THEN install the plugin from fresh.

    I copied all the information, and updated the “version” part of shareaholic_settings to be 8.4.3 and re-inserted the following:

    shareaholic_has_accepted_tos 1
    shareaholic_review_dismiss 1
    shareaholic_settings

    While leaving out the option shareaholic_perform_update – this allowed the plugin to install successfully, retaining all the previous settings. Obviously, I could have reverted to a previous state, but I wanted to actually see where this issue lived and post a resolution, as I had licence to break things here!

    Hope this helps someone out of a situation.

    Marking this resolved – well done with fast fix.

    Plugin Author shareaholic

    (@shareaholic)

    @robscott thank you SO MUCH! Your debugging was incredibly useful.

    SiteGround hooked us up with a test account this morning and we were able to replicate the issue. Their lead plugin developer is looking into it, too. The issue only affects SiteGround hosting customers, which is why it slipped by in our testing.

    That said, I believe we now have a fix that will allow everyone on SiteGround to seamlessly re-enable Shareaholic / update to the latest version:

    v8.4.4 – https://wordpress.org/plugins/shareaholic/#developers

    Each environment and situation can be just little different. Can you please let me know if the latest update works for you? It did on our test SG setup!

    I appreciate you sticking with us through this,

    Jay

    v8.4.3 worked for me, after I cleared out wp_options as described. 8.4.4 also works. Going straight to 8.4.4 will most likely “just work” for anyone who never updated (could test on the live site, but actually outside of our remit in this case 🙂 )

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘v8.4.2 Update Whitescreens Site’ is closed to new replies.