WordPress.org

Support

Support » Plugins and Hacks » [Resolved] v4.0.3 doesn't work properly

[Resolved] v4.0.3 doesn't work properly

  • Wil

    @limecanvas

    When updating to v4.0.3 our button and column shortcodes broke.

    I’ve restored to v3.9.5 and they are working nicely again.

    The buttons seemed to lose all formatting and the columns percentages were incorrect.

    Didn’t matter which browser I viewed the site on.

    Seems like the CSS isn’t being applied correctly in v4.0.3 in our circumstance.

    http://wordpress.org/plugins/shortcodes-ultimate/

Viewing 15 replies - 1 through 15 (of 17 total)
  • Wil

    @limecanvas

    BTW we don’t run it in compatibility mode.

    Plugin Author Vladimir Anokhin

    @gn_themes

    Wil

    @limecanvas

    Also doesn’t work with 4.0.1. Couldn’t test with 4.0.0 as the file gives a 404 error from SVN respository.

    Here’s the 3.9.5 version (working):
    http://awesomescreenshot.com/0fc1pwol90

    Generates this button code:
    <a href="#signup" class="su-button su-button-style-3 su-button-class" style="background-color:#e1750f;border:1px solid #b45e0c;border-radius:6px;-moz-border-radius:6px;-webkit-border-radius:6px;"><span style="color:#fcf1e7;padding:10px 22px;font-size:17px;height:17px;line-height:17px;border-top:1px solid #f6d6b7;border-radius:6px;text-shadow:-1px -1px 0 #b45e0c;-moz-border-radius:6px;-moz-text-shadow:-1px -1px 0 #b45e0c;-webkit-border-radius:6px;-webkit-text-shadow:-1px -1px 0 #b45e0c;">Sign Up Now</span></a>

    Here’s the 4.x version (not working):
    http://awesomescreenshot.com/0651pwp850

    Generates this button code:
    <a href="#signup" class="su-button su-button-style-3" style="color:#e1750f;background-color:#2D89EF;border-color:#246ebf;border-radius:6px;-moz-border-radius:6px;-webkit-border-radius:6px" target="_self"><span style="color:#e1750f;padding:0px 18px;font-size:14px;line-height:28px;border-color:#6cacf4;border-radius:6px;-moz-border-radius:6px;-webkit-border-radius:6px;text-shadow:0 0 1px #1b528f;-moz-text-shadow:0 0 1px #1b528f;-webkit-text-shadow:0 0 1px #1b528f"> Sign Up Now</span></a>

    Cache turned off.

    Wil

    @limecanvas

    OK – v3 not compatible with v4.x

    It would have been nicer to fork the plugin as this is going to break a lot of sites on updating 🙁

    Something to think about for future incompatible upgrades.

    Wil.

    This is a disaster. What kind of developer does this? You’ve just alienated everyone using previous versions. What, I need to redesign my entire site now?

    Plugin Author Vladimir Anokhin

    @gn_themes

    I made this disaster. Sorry. I’m so sad about that. But you can always remove my plugin and forget about this discussion, like you forget about this message – http://clip2net.com/s/5LkIRj that was placed at plugin page over a YEAR.

    So because you posted a warning A YEAR AGO I’m supposed to be thankful that you screwed over thousands of people by making a new plugin version that doesn’t behave with your old one?

    Nonsense.

    Plugin Author Vladimir Anokhin

    @gn_themes

    Complaints about free software – that’s nonsense.

    Remove this plugin and the problem will be solved immediately. You are not the first and unfortunately not the last person that complains about the fact that I spent a lot of personal time to create a new version.

    Thank you for your appreciation =)

    btw — if you wanted to release a new version, then call it something different so people can make the switch gracefully. As it is, your new version overrides the old version and breaks everything. Why not release with a new name so people can start replacing their old shortcodes systematically and not have to redesign their entire site at once?

    It’s upsetting when people don’t put just a little bit of thought into important things like this…

    Plugin Author Vladimir Anokhin

    @gn_themes

    Sorry, I’m not sure that I have translated your message correctly. Are you just call me dumbass?

    esmi

    @esmi

    Forum Moderator

    @vladimir Anokhin: I have removed that offensive message. That kind of behaviour is not tolerated on these forums.

    esmi

    @esmi

    Forum Moderator

    if you wanted to release a new version, then call it something different so people can make the switch gracefully.

    @kevin Geary: That is not how WPORG hosted plugins work.

    sleenmg

    @sleenmg

    I also had major problems with my upgrade and decided to go back to the previous version. I was using the vertical tabs and columns and when I upgraded, my columns were messed up and all of my tabs went horizontal. Plus my customizations went away.

    When I have time I will try the updated version on my test site and see if i can figure out a way to work with it. Still love the plugin.

    stermie

    @stermie

    Removing the plugin will NOT solve the issue for those who are angry about the update changes. Your shortcodes will remain behind and you will still have to manually remove them from all of your pages. The plugin author just continues to show a bad attitude by suggesting this as well as his other support posts about this plugin.

    Unfortunately I have used this plugin for quite some time and I do like the new changes (if starting from scratch) so I will have to go through all of my sites and manually make the changes needed to make it work for my clients.

    This is a prime example of why WordPress needs to adopt a similar plugin checks and balances system to what Envato has started to implement with Themeforest.net for themes.

    GravitySailor

    @gravitysailor

    This upgrade has caused me an entire day of remediation….a nightmare

    I will still use the plugin but very disappointed with manner of update

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] v4.0.3 doesn't work properly’ is closed to new replies.