Support » Plugin: WP RSS Aggregator » [v4.13.2] “Open in new tab” function doesn’t work anymore

  • Resolved cwaras

    (@cwaras)


    Hello,

    Since the deployment of this version, with the default template (not used) links “read more” opens in the same window, and no longer in a new tab as before.

    Thank you.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Mark Zahra

    (@markzahra)

    Hi @cwaras, you mentioned the default template is “not used”. Can you please clarify how you’re displaying the imported items and what template is being used?

    Is the template being used set to have an open link behaviour of new tab?

    cwaras

    (@cwaras)

    No template, just personnal formatting

    cwaras

    (@cwaras)

    @markzahra
    I just tested on my development environment, after downgrade on v4.13.1, when I click on the link “read more”, it opens a new tab.
    There is a problem here with v4.13.2
    Thx

    • This reply was modified 2 months ago by  cwaras.
    • This reply was modified 2 months ago by  cwaras.

    For information the “set as no follow” option probably does not work either.

    @mekku look here : https://swing.nc
    After each rss title link “lire la suite” (“read more” in english)
    (But now it open in a new tab because i downgrade v4.13.1)

    • This reply was modified 1 month, 2 weeks ago by  cwaras.
    Plugin Author Miguel Muscat

    (@mekku)

    Thanks for the link @cwaras. It’s helped to identify a potential cause for the problem. Are you by any chance able to save the template without errors?

    @mekku “Are you by any chance able to save the template without errors?”
    Sorry, i don’t understand, could you illustrate ?
    Thx

    Plugin Author Mark Zahra

    (@markzahra)

    @cwaras Miguel was referring to opening the page for a Template and saving it. You can access the list of templates from RSS Aggregator > Templates in your dashboard menu.

    For the feed on the https://swing.nc website, can you please send us the URL of the RSS feed you are displaying there? It’s the one you used when you set up the Feed Source.

    @sziszu, can you also share the URL of your RSS feed source/s and the page where you have the feed items being displayed?

    Also, a question for both of you – are you using the shortcode or the block to display the feed items on your sites?

    @markzahra yes, i am able to save the template without error
    The URL of the RSS feed is https://www.ibm.com/blogs/business-analytics/ibm-cognos-analytics/feed/
    I think i use shortcode (WP RSS Aggregator ‘function’)
    Somrthing like that :
    .show-all#actualites ul.rss-aggregator .feed-item {display: flex !important
    }

    #actualites ul.rss-aggregator .feed-item:nth-child(1) ,
    #actualites ul.rss-aggregator .feed-item:nth-child(2) ,
    #actualites ul.rss-aggregator .feed-item:nth-child(3) ,
    #actualites ul.rss-aggregator .feed-item:nth-child(4) ,
    #actualites ul.rss-aggregator .feed-item:nth-child(5) ,
    #actualites ul.rss-aggregator .feed-item:nth-child(6) ,
    #actualites ul.rss-aggregator .feed-item:nth-child(7) ,
    #actualites ul.rss-aggregator .feed-item:nth-child(8) {
    display: flex;
    }

    for “read more” :
    #actualites ul.rss-aggregator .feed-item > a::after {
    content: ” – Lire la suite”;
    font-weight: 100;

    AND to call :
    <section id=”actualites”>
    <div class=”container”>
    <div class=”row flex wow fadeInUp” data-wow-delay=”0.1s” data-wow-duration=”1s”>
    <div class=”col-lg-6 order-last”>
    <h2>Actualit├ęs IBM</h2><hr />
    <div class=”flux”>
    <?php echo do_shortcode(‘[wp-rss-aggregator]’); ?>
    </div>

    </div>
    <div class=”col-lg-6″><div class=”illus”></div></div>
    </div>
    </div>
    </section>

    I’m new to this plugin, but came to Support for this exact error.

    StudioPress theme. Have tried using both the block and the shortcode; have used the default WP RSS Agg template and one I made. “Open links behaviour” will neither open in a new tab or in a lightbox. Additionally, the default template began consistently generating a “Something went wrong. Template is not saved!” notice after I had initially tried to resave it with the “Open links in a new tab” option selected.

    Plugin Author Mark Zahra

    (@markzahra)

    Hey folks, we’re continuing to investigate these issues. They have been inconsistent so far, so we’re trying to find the possible cause or causes.

    @cwaras can you reproduce the same issue of you use the [wp-rss-aggregator] shortcode or our WP RSS Aggregator block?

    @sziszu had you removed your original message by any chance? What was your exact issue with those RSS feeds and shortcode? Is it also the opening in new tab?

    @vanderbeam can try deleting and re-installing the core plugin to see if the template saving issue persists? If it does, would you mind sharing the system info from the Debugging page under “RSS Aggregator”?

    To all, please open separate threads for your issues in the future. You may each have the sam symptoms but completely different reasons for them, so it becomes more difficult this way to figure things out.

    cwaras

    (@cwaras)

    @markzahra sorry Mark but i have downgraded in v4.13.1 so i can’t try

    Plugin Author Mark Zahra

    (@markzahra)

    @cwaras I understand, we do have an update being scheduled for next week that should address this issue, version 4.14. If it does not, please let us know.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.