Support » Plugin: Genericon'd » v4.0 not working

  • Resolved sunryzer

    (@sunryzer)



    The new version of the plugin doesn’t appear to be working.

    In the settings page, none of the options are checked. If I check them and save, the page reloads with none of them checked again.

    I’ve taken a look at the database entry in the options table and it is never modifying that – the default values a:2:{s:7:”sprites”;s:3:”yes”;s:8:”minified”;s:2:”no”;} remain and never change.

    I’ve tried deleting the plugin and re-installing with no luck.

Viewing 15 replies - 1 through 15 (of 23 total)
  • Hi, same problem as you. Since the 4.0 update i have a big space instead of the icon.
    No options checked, maybe normal ? seems strange.

    WordPress 4.6.1 FR avec le thรจme Flatsome.

    Thanks for help !

    Plugin Author Ipstenu (Mika Epstein)

    (@ipstenu)

    ๐Ÿณ๏ธโ€๐ŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    UGH! I think I see why.

    Would you be willing to try https://github.com/Ipstenu/genericond/blob/REL_4.0.1/genericons.php ? I just tested it locally and it works. What was happening was on SAVE it deleted things *facepalm*

    Exactly the same problem for me.
    Impossible to save.
    And a big white space instead of the icon.

    I just copy-paste the 3.3 version, and big whtite space disapear but the icons aren’t coming back.
    ๐Ÿ™

    I like the repeat and size function, no other plugin make that !
    [genericon icon=stop size=2x repeat=3]

    Thanks Mika – I put the 4.0.1 code in from Github, deactivated the plugin, deleted the options entry in my database and then reactivated the plugin and it works ๐Ÿ™‚

    For anyone upgrading from 3.3, I recommend the default setting to be Legacy and Classic Genericons – otherwise it will break websites. I know that kinda defeats the object of the 4.0 rewrite but you need to gradually transition people away from the old icon set and towards the new without annoying too many people (my software engineering background kicking in there!).

    Is there any way to use Genericons Neue in Menus? I copied in the SVG code from genericons.com but that triggers an error in my browser at it looks like XML injection.

    Thanks ๐Ÿ™‚

    • This reply was modified 1 year, 8 months ago by  sunryzer.

    Out with this plugin, in with “Better Font Awesome”.

    I am using Genericons in quite a few websites for me and clients. After updating the Plugin i had the same issue with it as sunryzer and eric4969. I have deleted the plugin-folder on my ftp and changed it with the older version and it works. I really hope, that i can use it in the future with the update from the update ๐Ÿ˜‰ Best Regards, Joachim

    Same problem here. The new version completely destroys several of my pages. Does any body still have the installation pack for 3.4.1 or another old version? I’d be very thankful for that!

    I try the method of Sunriser, but how to “deleted the options entry in my database” ?
    wich table or line ? thanks.

    @thaqy

    The earlier versions are available via the plugin’s developers tab:
    https://wordpress.org/plugins/genericond/developers/

    regards Jason

    @eric4969

    I try the method of Sunriser, but how to โ€œdeleted the options entry in my databaseโ€ ?
    wich table or line ? thanks.

    It’ll be in your “options” table (there’ll likely be some prefix before “options” for security reasons).

    Search the database for where “option_name” is “genericons_options” and delete that entry.

    thanks Sunryser.

    I was very hopeful, that another update would solve the problem. I don’t want to work within my database, just to get my plugins running. Always having in mind, that we are talking about a completely free product, my question to the developer is: Will this issue be resolved with an update? I have tried it today, but still having that problem and again installed 3.4.1. Thank you for giving me hope in advance :-))

    Plugin Author Ipstenu (Mika Epstein)

    (@ipstenu)

    ๐Ÿณ๏ธโ€๐ŸŒˆ Halfelf Rogue & Plugin Review Team Rep

    I have NO idea why this didn’t notify me. v 4.0.1 is out and should fix things, but some people have reported still needing to wipe out transients. I think that’s caching at it’s worst ๐Ÿ™

    I tried 4.0.1 – deleted transients and caching – still wouldn’t save settings or show icons.
    Returned 3.4.1.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘v4.0 not working’ is closed to new replies.