Support » Plugin: Team » V4.0 does not work at ALL

  • Resolved Julie Lawrence

    (@julie-lawrence)



    When we upgraded to version 4, we could no longer see any of our teams or groups in the back end, or the front end. When I look in the database, they’re actually still there.

    After several hours of reading your plugin code, and exploring our database, I worked out that Version 4 of your plugin changes everything – file names, post_type names, everything. So it doesn’t find the entries in our database, listed under post-type “tshowcase”, because you’ve changed that to “team_mf”. Ditto with everything else.

    I notice our site history shows that the plugin was deactivated when it couldn’t find tshowcase.php … perhaps you’d written some code to update those things in the database, but it didn’t run because of the file name changes?

    The other thing is that you’ve removed Settings … we had changed things in settings, so those things were no longer available to us … again, maybe that’s why it broke for us?

    Anyway, major fail … I finally managed to download a backup from last week, extract the old version of the plugin and load it back into our site. Grrrrrr.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Author themepoints

    (@themepoints)

    Hi,
    Thanks for your details information. we are not releasing version 4.0. we release team version 1.4. maybe you installed another vendor plugin but unfortunately the same post type conflict with this plugin. can you please check your plugin information carefully. it better for us to check this issues.

    Regards

    Julie Lawrence

    (@julie-lawrence)

    I’m sorry, I meant V1.4, not v4, my mistake. Thanks for replying! I’m still confused … did you change your filename and slugs? It seems that everything is different now?

    developerchick

    (@developerchick)

    We are having the same problem, we had to completely deactivate the plugin for the time being. Please help! Trying to update to 1.4 version.

    Plugin Author themepoints

    (@themepoints)

    Hi,
    We do not change any core file or slug we just update our plugin admin interface and unlock some pro version features into the free version also fix some CSS issues. we are working on it figured out this issues. if you need urgent help please contact us via our website contact form. our developer checks and assists you.

    Tegards

    Julie Lawrence

    (@julie-lawrence)

    Oh wow, I’ve finally worked out what’s going on. “Easy Updates Manager” pluginn which does automatic plugin updates, had incorrectly updated our “Team Showcase” plugin, by cmoreira, by replacing it with YOUR plugin … weird!!!

    Sorry for the confusion!!

    cheers,
    Julie

    developerchick

    (@developerchick)

    Maybe that is what is going on with ours except we just did the manual update via the admin area of the site. I thought Team Showcase was you as well. Is it not?

    @developerchick, yep, no doubt … apparently they have the same slug, so they’re getting confused by the update mechanism. Seems crazy, right? I’ve had to stop auto-updates, otherwise it just keeps happening. Good luck!

    cheers,
    Julie

    @julie-lawrence, that is crazy. Has anyone contacted the other author yet?

    The team showcase plugin that I have been using for the past 4 years is Team Showcase | Version 1.3.8 | By Carlos Moreira | https://cmoreira.net/team-showcase/
    https://codecanyon.net/item/team-showcase-wordpress-plugin/4936368

    Somehow in the WordPress System this has been linked to your plugin and is replacing his plugin with yours by mistake. I restored the correct plugin and solve my issues, but am curious how this happened.

    Thanks, Brian

    Wow, I had the same problem. It killed the site completely. Thanks @briancorder and @julie-lawrence for figuring out what was going on. Hopefully these guys can inform WordPress of the issue.

    Plugin Author themepoints

    (@themepoints)

    Thanks, everyone for inform this issues. we are also not happy with this issues. it, not only our plugin issues, the Main reason is the plugin name. both plugins come with the same name (team-showcase). plugin display name is not fact & both plugins approved different repository (Codecanyon & WordPress).

    That’s why Themforest requiring unique, non-generic names with at least 3 characters for all new submissions. In addition to this author’s shouldn’t use names that are already on the Marketplace.

    Regards

    Has this been resolved?

    No, it hasn’t … any idea who we need to tell???

    If you use the plugin I do (codecanyon) go to your code canyon purchases and download the latest version and install it. It will no longer try and update the theme points version.

    This has solved my issue

    Hi Everyone. Carlos Moreira here, the author of the Team Showcase plugin on Codecanyon. This is a namespace issue related with the way WordPress looks for updates, like themepoints have already pointed out. 5 years ago when I released my plugin the name and slug was unique, so I couldn’t predict this.

    It will only happen on older versions of my plugin (+3years old). If you go into your downloads section on codecanyon to download and install the latest version of my plugin, you’ll get all your data back and this shouldn’t happen again hopefully.

    I would also recommend you to use the ‘Envato Market‘ plugin so it automatically updates envato market plugins.

    This is no one’s fault, something that already happened to other plugin and theme developers. Just a something that wordpress itself might need to improve.

    I am available to help with any other issue related with my plugin, you can contact me using the support channels if needed.

    I wish good luck to themepoints, seems like a nice plugin, good job. Just wish the slug was not the same, but now it’s too late 🙂

    Cheers, Carlos

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.