v3.0.1 wp-admin left menu problems (29 posts)

  1. PBloggers
    Posted 4 years ago #

    Brand new install of 3.0.1, no added plugins, defualt theme. (Linus, Apache, PHP5 mysql5).

    2 bugs...

    1. When I click on "Comments", the page that loads stops at menu item Plugins, shows nothing else and all down arrows do not work.

    2. When I click on "Menus" under "Appearance", same as #1 AND am getting a js error 'postboxes' is undefined load-scripts.php Line 157

    I have to believe these are 3.0.1 problems because I have another website using 2.9.2 and have no problems.

    Any ideas?

  2. Try downloading WordPress again and delete then replace your copies of the /wp-admin/ and /wp-includes/ directories with fresh copies from the download.

  3. PBloggers
    Posted 4 years ago #

    James, did exactly as you suggested and it made no difference, still having the exact same 2 issues.

  4. Try increasing PHP's memory allocation. It probably won't work, but it's worth a try. Here are four ways to increase PHP's memory allocation:

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M
    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '64M');
    4. Talk to your host.
  5. PBloggers
    Posted 4 years ago #

    James, tired it and still no luck. I have a dedicated server which has 12gig of ram and dual quadcore processors. It's odd because the other wordpress site I have is 2.9.2 and it works fine. Am not using multi-site. I tried looking at the code but it is rather convoluted and very hard to follow.

    Any idea where I might could go to get some additional help?

  6. Try making a second installation of WP 3.0.1 with a new database and new files in a new directory. See if that one exhibits the same issue.

  7. PBloggers
    Posted 4 years ago #

    James, that is essentially what I have done. My first attempt at 3.0.1 was by upgrading a site that was at 3.0.1. That's when the above issues started. I rolled that site back to 2.9.2 and set up a new domain, new databases, new location to use as a sandbox for 3.0.1. Alas, same issues. As I said before I did redownload 3.0.1 then uploaded the wp-admin and wp-includes which made no difference. I am really stumped and can't believe I am the only person in the world with this issue.

  8. Try adding define('CONCATENATE_SCRIPTS', false); to your wp-config.php file. Place it below the define('DB_HOST', 'localhost'); line.


  9. PBloggers
    Posted 4 years ago #

    James, looks like we are going in the right direction, while it did not fix the problem, now the left menu stops at Appearance, it no longer put out the Plugins menu entry. Do you have any more ideas?

  10. Try testing it in a different browser and on a different computer if you can.

  11. PBloggers
    Posted 4 years ago #

    Tested on 3 different computers in IE8, Firefox and Opera, same thing on them all, puts out Appearance link then quits building anymore.

  12. Try increasing PHP's maximum execution time. Add this line to your php.ini file and increase as necessary:

    max_execution_time = 600 ;

  13. PBloggers
    Posted 4 years ago #

    Our max execution time is in excess of 6000 as we have a couple of long running scripts on other domains.

  14. By any chance, do you have any other server environments to test on, or just this one?

  15. PBloggers
    Posted 4 years ago #

    Only 1 Linux server, our other one is windows. Do you know if anyone else has had this issue with 3.0.1?

  16. Honestly, this is the first that I've heard of it. Does everything else in the admin panel look fine? Is there any strange formatting going on?

  17. PBloggers
    Posted 4 years ago #

    Everything else seems to work fine, I can access all other menu options.

  18. In that case, I'm completely out of ideas. :(

  19. PBloggers
    Posted 4 years ago #

    ok, update time..... I had the PHP upgraded from 5.1.6 to 5.2.14 and that fixed the comments and menus problems. Now however, I get the same thing as before with Users and Users worked before.

    My mysql was also upgraded so my system is fairly up to date and wordpress 3.0.1 should work from a clear install with no issues, why am I now having problems with Listing the Users (of which there are 2) and the dashboard page is blank.

    Is wordpress 3 really ready for primetime?

  20. Is wordpress 3 really ready for primetime?

    Of course, or there'd be millions of users with your problem, and I would have at least heard of it by now.

    Hang in there while I call in backup on this topic.

  21. If you view the source of the page, does it list any error messages at the bottom?

    Try enabling debug mode by adding this to your wp-config:

    define('WP_DEBUG', true);

    That will make it print errors which might otherwise normally be hidden.

    Basically, something is stopping page execution. Before you can fix it, you have to know what that something is.

  22. Yep, and see if anything is being logged in any error logs on the server.

  23. esmi
    Forum Moderator
    Posted 4 years ago #

    I had the PHP upgraded from 5.1.6 to 5.2.14

    Why not 5.3? I recall one of the other theme developers having problems with a bug in 5.2.x recently. Pretty sure it was 5.2.14...

  24. PBloggers
    Posted 4 years ago #

    Here is the last code (viewable via view source) for the main wp-admin page...

    <p><strong>Other WordPress News</strong> - Shows the feed from <a href="http://planet.wordpress.org" target="_blank">WordPress Planet</a>. You can configure it to show a different feed of your choosing.</p><p><strong>Plugins</strong> - Features the most popular, newest, and recently updated plugins from the WordPress.org Plugin Directory.</p><p><strong>For more information:</strong></p><p><a href="http://codex.wordpress.org/Dashboard_SubPanel" target="_blank">Dashboard Documentation</a></p><p><a href="http://wordpress.org/support/" target="_blank">Support Forums</a></p></div>

    Here is the last code when you click on "Users"....

    <div class='wp-menu-image'><a href='plugins.php'><br /></a></div><div class="wp-menu-toggle"><br /></div><a href='plugins.php' class="wp-has-submenu menu-top menu-icon-plugins" tabindex="1">Plugins <span class='update-plugins count-0'><span class='plugin-count'>0</span></span></a>
    <div class='wp-submenu'><div class='wp-submenu-head'>Plugins <span class='update-plugins count-0'><span class='plugin-count'>0</span></span></div><ul><li class="wp-first-item"><a href='plugins.php' class="wp-first-item" tabindex="1">Plugins</a></li>

    In neither case was there any error message generated. My hosting company does not like to be at the most current release of any software due to potential security bugs. If there are restrictions for certain releases of PHP and mySQL I would think they would be documented. Our other wordpress site which is at 2.9.2 works flawlessly.

  25. christopherross
    Posted 4 years ago #

    I would suspect that James is on the right track here, although there could be two problems you're encountering.

    Either a memory issue on the server, in which case increasing WP's memory in the wp_config.php file:

    define('WP_MEMORY_LIMIT', '64M');

    As well as an .htaccess file fix of:

    php_value memory_limit 64M

    and finally the php.ini update:

    memory_limit = 64M ;

    Do keep in mind that some servers require the .htaccess and php.ini changes to be located in the wp-admin folder, not the root. I've seen situations where it even needed to be placed in the wp-includes directory and wp-content to work properly for uploaded.

    The second issue I've encountered on some hosting environments which causes an issue similar to this is permissions. If the above doesn't work, try changing all the files and all sub directories to 777, see if that helps. Obviously you don't want to keep it at this level but as a test it will help clarify if it's the server's permission settings.

    Finally, it may simply be the server. Run phpinfo() to ensure that your server is running everything it needs. I have 3.0.1 installed in around 30 server configurations across a variety of hardware and software, there are hiccups on some but not on most.

    Hope that helps.

  26. Andrew Nacin
    Lead Developer
    Posted 4 years ago #

    This is a textbook memory limit issue. Check your error logs and follow the steps outlined.

  27. codergeek82
    Posted 4 years ago #

    I am facing exactly the same issue, check error below:

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; chromeframe; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.30729; InfoPath.2; .NET CLR 3.0.30729; .NET4.0C; .NET4.0E)
    Timestamp: Tue, 2 Nov 2010 18:15:14 UTC

    Message: 'postboxes' is undefined
    Line: 157
    Char: 3499
    Code: 0
    URI: http://mywebsite.com/wp-admin/load-scripts.php?c=0&load=jquery,utils,nav-menu&ver=2b05c108d9016a4caa470b8edaf40953

    My theme is Hybrid News 0.2
    Apache version 2.2.16
    WP version: 3.0.1
    PHP version 5.3.3
    memory_limit 32M

    PBloggers, you are not alone.
    BR, codergeek82

  28. hmenzi
    Posted 4 years ago #

    Same thing happening to me, just after I was playing around with the Menu's page under appearance. I can not seem to get this to work, may end up looking into the database to fix.

    Webpage error details
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; InfoPath.2; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET CLR 1.1.4322)
    Timestamp: Wed, 3 Nov 2010 05:07:25 UTC

    Message: 'postboxes' is undefined
    Line: 157
    Char: 3499
    Code: 0
    URI: http://mysite.com/cp/wp-admin/load-scripts.php?c=1&load=jquery,utils,nav-menu&ver=2b05c108d9016a4caa470b8edaf40953

  29. nicdvs
    Posted 4 years ago #

    Hey, I have the same problem, I tried deactivating all plugins, switched theme, allocating more memory to scripts... nothing work.. When I set WP_DEBUG to true, I get these errors in the 'Position' box.. I do not recall seing this box before thought..

    Notice: Trying to get property of non-object in /var/www/vhosts/theotherside.ca/subdomains/focuseye/httpdocs/wp-includes/nav-menu.php on line 620
    Notice: Trying to get property of non-object in /var/www/vhosts/theotherside.ca/subdomains/focuseye/httpdocs/wp-includes/nav-menu.php on line 621
    Notice: Trying to get property of non-object in /var/www/vhosts/theotherside.ca/subdomains/focuseye/httpdocs/wp-includes/taxonomy.php on line 2507
    Catchable fatal error: Object of class WP_Error could not be converted to string in /var/www/vhosts/theotherside.ca/subdomains/focuseye/httpdocs/wp-includes/formatting.php on line 433

Topic Closed

This topic has been closed to new replies.

About this Topic