• Resolved Kalacta

    (@rocafresh)


    I have tried database migration via wordpress backend and wp-cli. Both methods fail – now EDD is broken. Here is error message:

    Migrating Payments  0  % [>                                                                                                        
    ] 0:00 / 0:00Fatal error: Uncaught Error: The script tried to modify a property on an incomplete object. Please ensure that the class definition "Wpil_Model_Link" of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide an autoloader to load the class definition in /home/adambox/public_html/wp-includes/formatting.php:5010
    Stack trace:
    #0 /home/adambox/public_html/wp-includes/formatting.php(5005): map_deep(Object(__PHP_Incomplete_Class), 'stripslashes_fr...')
    #1 /home/adambox/public_html/wp-includes/formatting.php(2799): map_deep(Array, 'stripslashes_fr...')
    #2 /home/adambox/public_html/wp-includes/formatting.php(5634): stripslashes_deep(Array)
    #3 /home/adambox/public_html/wp-includes/meta.php(53): wp_unslash(Array)
    #4 /home/adambox/public_html/wp-content/plugins/easy-digital-downloads/includes/orders/functions/meta.php(30): add_metadata('edd_order', 236650, 'wpil_links_inbo...', Array, false)
    #5 /home/adambox/public_html/wp-content/plugins/easy-digital-downloads/includes/admin/upgrades/v3/class-data-migrator.php(1295): edd_add_order_meta(236650, 'wpil_links_inbo...', Array)
    #6 /home/adambox/public_html/wp-content/plugins/easy-digital-downloads/includes/class-edd-cli.php(1339): EDD\Admin\Upgrades\v3\Data_Migrator::orders(Object(stdClass))
    #7 /home/adambox/public_html/wp-content/plugins/easy-digital-downloads/includes/class-edd-cli.php(833): EDD_CLI->migrate_payments(Array, Array)
    #8 [internal function]: EDD_CLI->v30_migration(Array, Array)
    #9 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Dispatcher/CommandFactory.php(100): call_user_func(Array, Array, Array)
    #10 [internal function]: WP_CLI\Dispatcher\CommandFactory::WP_CLI\Dispatcher\{closure}(Array, Array)
    #11 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Dispatcher/Subcommand.php(491): call_user_func(Object(Closure), Array, Array)
    #12 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(417): WP_CLI\Dispatcher\Subcommand->invoke(Array, Array, Array)
    #13 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(440): WP_CLI\Runner->run_command(Array, Array)
    #14 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Runner.php(1237): WP_CLI\Runner->run_command_and_exit()
    #15 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/WP_CLI/Bootstrap/LaunchRunner.php(28): WP_CLI\Runner->start()
    #16 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/bootstrap.php(78): WP_CLI\Bootstrap\LaunchRunner->process(Object(WP_CLI\Bootstrap\BootstrapState))
    #17 phar:///usr/local/bin/wp/vendor/wp-cli/wp-cli/php/wp-cli.php(27): WP_CLI\bootstrap()
    #18 phar:///usr/local/bin/wp/php/boot-phar.php(11): include('phar:///usr/loc...')
    #19 /usr/local/bin/wp(4): include('phar:///usr/loc...')
    #20 {main}
      thrown in /home/adambox/public_html/wp-includes/formatting.php on line 5010
    Error: There has been a critical error on this website.Learn more about troubleshooting WordPress. There has been a critical error on this website.
    

    Wordpress version 6.0.1
    PHP version 8.1

    • This topic was modified 4 months, 2 weeks ago by Kalacta.
    • This topic was modified 4 months, 2 weeks ago by Kalacta.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Chris Klosowski

    (@cklosows)

    @kalacta,

    Sorry for the disruption of service, but looking at this error log it looks like some other plugin or theme has added some meta data to an EDD Payment, that has a meta key of wpil_links_inbo... (it gets cut off here, but maybe ‘inbox’ is the rest of this meta key?).

    Can you try disabling some plugins that might have the initials WPIL and running the migration again?

    Thread Starter Kalacta

    (@rocafresh)

    Meta key for a plugin deleted years ago was still hanging around in database postmeta table. Resolved now. Thanks!

    The problem comes from LinkWhisper Plugin. The old plugin left “wpil_links_” (metakey) and “Wpil Model Link” (meta value) entries in wp_postmeta database table.

    What you can do before migration is to use the settings of the Free LinkWhisper Plugin to remove all legacy entries (Donwload Link Whisper Free Plugin from WordPress Plugin, go the the plugins setting page, activate the option “Delete all Link Whisper Data”, then unininstall and delete the Free LinkWhisper plugin again to execute this.

    Then try to run the migration to EDD 3.0.

    Hope that helps!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.