Support » Plugin: Events Manager - Email Users » v3.3 Gateway Timeout

  • Resolved snorklebum

    (@snorklebum)


    Hi,

    I have updated my test site to v3.3 and now when I try to send an email to attendees it just waits on the server responding then displays
    504 Gateway Time-out
    The server didn’t respond in time.

    The site logs are not showing any additional errors but enabling debug I can see

    Notice: Undefined index: filter in /wp-content/plugins/events-manager-email-users/includes/class-manual.php on line 213

    Notice: Undefined index: filter in /wp-content/plugins/events-manager-email-users/includes/class-main.php on line 455

    Let me know if you require any further info.
    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Patrick

    (@duisterdenhaag)

    “test site” does that mean a localhost? Because that makes it a different approach than a live site.

    On a localhost, Sendmail will not work, because the server has no “real” credentials (real domain name and DNS) linked to it. So, you will always need to use the plugin with SMTP method.
    A 504 time out, means your SMTP server is not responding. Did you doble check your settings in Events > Email Users?

    Aha… the 455 line can actually be deleted. (I’ll do that in the next update) That is from a beta version where you could only filter recipients in the settings and not the email form. I decided that selecting the filter in the email form would be more flexible.
    BTW, that filter is only shown if you have “Allow Double Bookings” = yes in your EM Settings.

    Have you tried updating the plugin settings? Simply go to the Email Users settings page and click “Update”. That should add the missing variable to default. It should have done so upon updating, but it seems that went wrong.
    🙁

    snorklebum

    (@snorklebum)

    Hi Patrick,

    MY test site is online on a subdomain with the same configuration as live. I’ve saved the config and that has made those notices disappear (although I note there is an update to remove this code).

    I also have another development server which I’ve just used to do some further testing which will hopefully help.
    3.2 using EM-EventUsers works
    3.4 using EM-EU shows Gateway Timeout (I have not saved settings)
    3.2 rolled back to 3.2 and tested, EM-EU works again.
    3.4 Upgraded again and saved configuration and tried emailing, still shows Gateway Timeout
    3.2 rolled back, now the plugin shows Gateway Timeout, assuming a setting is being changed which is specific to my setup.

    I have EM-EU setup to use SMTP, SSL on port 465

    *Update* If I change to sendmail, 3.4 works.
    Let me know if I can do any further testing.

    Thanks

    Plugin Author Patrick

    (@duisterdenhaag)

    Thanks for the info.
    I’m puzzled… The only thing I changed to the actual sending of the email was remove the additional SMTP Encryption.

    Yet, I just tested 3.4 on my live server (again) and indeed Sendmail does work, but SMTP times out. Both on 465 and 587.

    I will look into it.

    Plugin Author Patrick

    (@duisterdenhaag)

    Have you tried using port 587 as well?

    • This reply was modified 8 months ago by Patrick.
    snorklebum

    (@snorklebum)

    587 does indeed work where as 465 seems to cause time out, I’ll change the sites over to use this 587 instead. I’m guessing the removal of the SMTP encryption will break the 465 communication as it’ll expect SSL.

    Thanks again for your help!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘v3.3 Gateway Timeout’ is closed to new replies.