Support » Plugin: No Right Click Images Plugin » v3.2 breaks scrolling on mobile pages with images

  • Resolved leandroprz

    (@leandroprz)


    After updating to the latest version I can no longer scroll through my galleries with images.
    This used to happen to me when enabling “Disable Touch events”. I think the bug is caused by the new “Disable context menu on Apple devices” option. I tried disabling it but still I can’t scroll.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Keith P. Graham

    (@kpgraham)

    I was afraid that this would be an issue. I will see what needs to be done.

    Unchecking the option should do it. You might have to clear your browser cache or wait until Apple does it. In the mean time you can revert back to 3.1 version.

    I will release a new version in the morning.

    Keith

    Plugin Author Keith P. Graham

    (@kpgraham)

    I released 3.3 immediately. This gets rid of the check for tags with background images – not usually a problem, so you can scroll as long as you don’t touch a raw image. On the negative side, if you try to scroll by dragging an image, nothing will happen – you have to scroll by dragging a non-image part of the page.

    If it continues to be an issue you can unset the option (which is now off by default). Apple caches the css files so it may take a few reloads and some time before the new css is loaded.

    Copy and select will be stopped, but I don’t think I can stop dragging on IOS devices

    Keith

    leandroprz

    (@leandroprz)

    I updated the plugin and disabled the two options but the problem remains, it’s like even though I disabled them, they are still enabled.

    I deleted my WordPress installation cache and Safari’s and Chrome’s cache as well.

    Plugin Author Keith P. Graham

    (@kpgraham)

    I just went to your page on an iPad and the page displays and scrolls correctly.

    When I check the page source, the new code for Apple is not loading so you have that option unchecked. I can also hold on the image and get the context menu to save the image.

    The images are very very impressive and I understand why you would prefer that they not be downloaded.

    I must assume that safari or apple is caching web pages. I don’t know how long you have to wait to receive a refreshed page.

    I also noticed that you turned off touch events.

    Please let me know if the scrolling error resolves, and if there is a combination of options that protects your images. It is likely that any change that you make will involve waiting for the changes to hit your cache.

    I will make changes if the problem is not fixable.

    Keith

    leandroprz

    (@leandroprz)

    This is strange, it’s not working for me.
    I recorded a video so you can see exactly what my issue is: https://youtu.be/Gt1nzrEHg4s

    These are my settings right now:
    – Allow Right Click for Logged Users: ON
    – Disable Dragging of images: ON
    – Disable Touch events: OFF
    – Disable Gesture events: OFF
    – Disable context menu on Apple devices: OFF

    It works fine on desktop, but not on mobile. And it was working fine before v3.2

    Plugin Author Keith P. Graham

    (@kpgraham)

    You have basically turned off the plugin.

    You need to refresh the page to get a new copy of everything.

    I’ve tested on my ipad mini, my iPhone 5s and my old iPhone 4s and the scrolling works.

    You can go back to the old version and try it again.

    Keith

    leandroprz

    (@leandroprz)

    I turned off everthing related to mobile to see if that would make it work again. I refreshed the page, tried with Chrome, nothing worked.

    I just went back to v3.1 and everything works as expected.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘v3.2 breaks scrolling on mobile pages with images’ is closed to new replies.