WordPress.org

Support

Support » Plugins and Hacks » V2.2.5 breaks slider – php warning

V2.2.5 breaks slider – php warning

  • Error is “too few arguments in …slider-template.php”
    Theme is Ftheme’s Bizcast
    Same error in earlier version was fixed in 2.2.4 on one site.
    On another site 2.2.4 conflicted with the Placester plug in.
    Now on another site with all other plug ins deactivated I get the same error.
    The only option is to deactivate Jetpack.

    http://wordpress.org/extend/plugins/jetpack/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jeremy Herve

    @jeherve

    This error seems to be related to your theme, since Jetpack doesn’t include any “slider-template.php” file.

    Could you contact the theme author and let them know about this issue?

    Right, but it’s not just one theme/author – as you know, there are tons of questions about conflicts with Jetpack here and elsewhere. The likelihood is users will just deactivate Jetpack rather than trying to get the themes adjusted.

    Initially that’s what I did but then I narrowed it down to the Photon plug in in Jetpack. With that piece deactivated, the errors I’ve seen seem to go away.

    Plugin Author Jeremy Herve

    @jeherve

    I narrowed it down to the Photon plug in in Jetpack. With that piece deactivated, the errors I’ve seen seem to go away.

    Could you then let the theme author know about the incompatibility? If you give them the exact error message displayed in your browser console, along with the line where the error happens in slider-template.php, they will be able to update their theme to support Photon.
    Do not hesitate to send them a link to this thread, we’d be happy to figure out how to solve the incompatibility with them!

    Sure, I will do that.
    FYI: another site I manage was getting memory exhausted errors as soon as Jetpack was updated by the user – but this time in the admin back end only. Disabling Jetpack once again fixed the problem.
    So since the common cause seems to be Jetpack, it might be easier to address from Jetpack’s end rather than trying to get all these themes fixed.

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 68384 bytes) in /home/xxxxxxx/public_html/wp-admin/includes/admin.php on line 50

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘V2.2.5 breaks slider – php warning’ is closed to new replies.