Support » Plugin: Elementor Page Builder » v2.7 not stable

  • Hello, I’m trying to update websites with the latest version and I notice:
    – The editor does not work (except on the theme builder)
    – The separation widgets used lose their settings

Viewing 15 replies - 1 through 15 (of 29 total)
  • Same here! And finally the update stopped database server.

    I am a Happiness Engineer at WordPress.com and we are seeing issues on a number of sites hosted with us following the recent update as well. Here is an example of a problem query:

    Query       |   6147 | Sending data                                                          | UPDATE wp_154393025_postmeta SET meta_value ='wp-post'
                WHERE meta_key = '_elementor_template_type' && post_id in (
                    SELECT p1.ID FROM wp_154393025_posts AS p LEFT JOIN wp_154393025_posts AS p1 ON (p.ID = p1.post_parent || p.ID = p1.ID) WHERE p.post_type = 'post'
                )

    These seem to be coming from _v_2_7_0_rename_document_types_to_wp()

    Please let me know if there is any further information we can provide

    We’ve noticed numerous issues:

    – All the styling on pages disappeared
    – Update resulted in memory allocation error nmessages, this was resolved by de-activating the pro version then re-activating it.
    – Pages are failing to update in the “edit with Elementor” mode with an internal server error 500.

    The only way I’ve been able to get it back to a semblance of it’s working self is to duplicate pages withe a plugins, delete the originals and use the instate the duplicates as live pages. Luckily it’s a small site, I wouldn’t want to have to do that on a large site!

    Someone has dropped the ball here.

    I’ve noticed issues like this in the past, where widgets I was sure I’d styled had suddenly lost their style attributes, but have performed so many customizations that I couldn’t be certain what it was due to, and simply re-did it without enquiring further.

    Now I see that due to this update, this recognizable issue is much more severe, and may point to a long-lingering issue that finally needs to be addressed.

    Will refrain from updating until further notice…

    Same here. I cant upload pictures, it reports a database error. I’ll have to rollback =/

    After a rollback to version 2.6.8, a 500 error periodically occurred
    That’s generally sad

    • This reply was modified 2 months, 1 week ago by vaka2vaka.
    Plugin Support Lisa R

    (@lisaelementor)

    Hi all,
    Thank you all for your feedback.
    Our dev team has been notified and they will release a patch soon!

    Same here, 2.7 made the host CPU and memory spike and the site became unreachable.

    After about an hour the resources started dropping and we were getting database errors including too many connections in wp-db.php

    When we got back into WordPress Elementor was stuck trying to update the database in the background.

    The Elementor log shows:
    [info] elementor::elementor_updater Started
    [info] Elementor/Upgrades – _v_2_7_0_rename_document_types_to_wp Start
    PHP: showing 1 of 1
    [notice X 7][/public_html/wp-content/plugins/elementor/includes/conditions.php::86] Undefined index: url [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]

    Nothing showed up in our other WordPress logs.

    Rolled back to 2.6.8 from the tools menu, things seem okay at the moment.

    Hi, now I have the same problem that everyone describes but with the Version: 2.7.1 version that just came out, how can I go back to the previous version?

    pingram

    (@pingram3541)

    @antoniomanco you can go to Elementor > Tools on the back end and on the Version Control tab, choose 2.7.0 or even 2.6.8 or older.

    pingram

    (@pingram3541)

    I am on 2.7.1 updated from 2.6.8, skipping 2.7.0 altogether. Here is my test results so far:

    -no lingering database update message in wp-admin area
    -no styling on pages disappeared
    -no memory allocation error messages
    -can create new page and open Elementor editor – no 500 error
    -can drag and drop widgets, edit and save – no 500 error
    -can upload a new image to wp media library via image widget in E editor – no 500 error
    -can modify separator element settings and they are retained upon save
    -host resources look normal, minimal cpu/mem usage

    Let me know if there is anything else to test but 2.7.1 appears to patch the 2.7.0 issues on all of my development sites. Cheers!

    Hello,

    I did the update to 2.7.1 but I’m still experiencing the same issues as:
    – The editor does not work
    – The separation widgets used lose their settings

    But in “Safe Mode” everything works fine. I’d tried to disable plugins and theme, restart permalink etc..

    pingram

    (@pingram3541)

    If you go to the back end – Elementor > System Info and scroll to the bottom, do you see any errors?

    Also:

    – The editor does not work (does the browser console have any errors?)
    – The separation widgets used lose their settings (on the front end or in the editor in safe mode?)

    * https://duckduckgo.com/?q=open+browser+console

    I upgraded to 2.7.1 and got the following errors

    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 163840 bytes) in /home/dev4victvsco/public_html/wp-content/plugins/woocommerce-bookings/vendor/composer/ClassLoader.php on line 444

    Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 163840 bytes) in /home/dev4victvsco/public_html/wp-content/plugins/woocommerce/includes/class-wc-autoloader.php on line 54

    However, I installed the update with Elementor Pro active. After deactivating Elementor Pro then reactivating it the error message disappeared.

    I would therefore suggest deactivating both Elementor and Elementor Pro, installing the 2.7.1 then activating Elementor, then activating Elementor Pro

    Hey @pingram3541

    To answer your questions:

    If you go to the back end – Elementor > System Info and scroll to the bottom, do you see any errors?

    yes I have 8 error in js

    The editor does not work (does the browser console have any errors?)

    yes, about js also

    The separation widgets used lose their settings (on the front end or in the editor in safe mode?)

    on the front end, it’s good in safe mode and I can update the widget I used in the page but I can’t select any new widget.

    I tried to downgrade to 2.7.0 it seems it’s impossible, I don’t know why yet…

    Things I don’t know: what if I’m uninstall elementor and re-install it again, do I’ll lose all my layout ?

    Thanks for your answer btw 😉

Viewing 15 replies - 1 through 15 (of 29 total)
  • You must be logged in to reply to this topic.