Support » Fixing WordPress » V1.2 How to enable RSS

  • I cant seem to get RSS to work with my WP install. I Have WP installed on my page and the posting works fine and everything. I want to be able to turn my posts into RSS feeds. Is that possible? Did i mess something up?

    im useing 1.2-mingus is the site.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You don’t have to “turn your posts into feeds” rather you just have to provide the RSS feed link. Check out:
    There is your feed. You might want to put feed links on your sidebar menu as a courtesy. In the default index.php file in V1.2.2 you’ll find those links in the Meta section of the Menu div.

    thank you so much….my site is awesome now.

    You’re welcome, drazin! 🙂

    ok another question….how do i get my links and images to appear in my rss feed? right now its just an exceprt.

    Well, as far as images go, the whole idea behind RSS is that you just provide a good title and some interesting content and it will make people want to view the whole item and then when they click on the link to be taken to your site where they will see your image. RSS isn’t really meant to send the content of your site everywhere, rather the concept is to allow people to have some “headlines” if you will and scan through them until they find something of interest.

    I’m not by any means an expert on RSS, so you’ll have keep that in mind when reading my remarks. There may well be a way to send out your images via RSS. I suspect that if you do a search of the forums, you’ll find lots of good information on the RSS feeds.

    good call thanks.


    I was wondering why my RSS link seems to have gone offline. The link exists, but everytime anyone clicks on it, I get the following message:

    “The requested URL /feed/rss2/ was not found on this server.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.”

    I don’t recall having done anything to eliminate the feed, but…
    my site is at Any advice would be greatly appreciated.

    It’s due to passing your custom permalinks through index.php. I’d call it a bug, but basically when you use the permalink structure:


    This resets internal links in WordPress to vitual paths that will not work in some cases, as with the syndication links. To get around it, you can hard code your RSS links to their specific files. For RSS2:

    For the RSS2 comments link on individual posts (this is in your wp-comments.php file), use this for the link:

    /wp-commentsrss2.php?p=<?php the_ID(); ?>

    Ah, I see how it works. Thank you so much for your help!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘V1.2 How to enable RSS’ is closed to new replies.