Support » Plugin: Amazon Associates Link Builder » v1.9.0 issues

  • Hi guys,
    Apologies, I originally hijacked the v1.9 release thread (https://wordpress.org/support/topic/v1-9-0-of-plugin-released/) which has been locked off (understandably – apologies again!).

    PHP 7.2
    WP 5.0.3
    AALB 1.9.0

    When using v1.9 with the latest WP release (5.0.3), AALB prevents all <a> tags in the same post content from working. They all become “images” to a 1×1 image stored behind https://ir-(and then the rest of the URL – I’ll grab it in a bit for you). No console errors are logged

    HOWEVER, if I copy the shortcode that AALB generates, delete the AALB block and then paste the shortcode into the WP default shortcode block – everything works perfectly.

    I was also seeing a LOT of logs in my php-slow.log relating to AALB. It was making multiple calls (around 5 per minute) regardless of whether I was using a block or not. Furthermore, I was getting a LOT of errors logged relating to API usage, which is extremely surprising to me considering I haven’t used AALB for almost 6 months, due to the fact that it hasn’t been Gutenberg compatible. I will get examples from my logs for this for you.

    • This topic was modified 5 months, 2 weeks ago by  Will Stocks.
Viewing 15 replies - 1 through 15 (of 20 total)
  • I get hundreds (if not THOUSANDS) of the following errors (I’m talking 10MB+ of plaintext errors per day – it’s bogging down my logs!):

    PHP access logs: [04/Feb/2019:06:38:52 +0000] "POST /wp-admin/admin-ajax.php?action=aalb_update_table&nonce=ea32cd6f3d" 200 0 - 11882 12668 22.770 29360128 1.41% 0.44% "/wp-admin/admin-ajax.php?action=aalb_update_table&nonce=ea32cd6f3d"

    PHP slow logs: [04-Feb-2019 06:25:20] [pool clusternamehere] pid 11895 script_filename = /my/super/secret/server/public_html/wp-admin/admin-ajax.php [0x00007fc3dd41c5d0] usleep() /my/super/secret/server/public_html/wp-content/plugins/amazon-associates-link-builder/cron/update_table_cron_task.php:105 [0x00007fc3dd41c530] exponential_backoff() /my/super/secret/server/public_html/wp-content/plugins/amazon-associates-link-builder/cron/update_table_cron_task.php:82 [0x00007fc3dd41c450] task() /my/super/secret/server/public_html/wp-content/plugins/amazon-associates-link-builder/vendor/a5hleyrich/wp-background-processing/classes/wp-background-process.php:303 [0x00007fc3dd41c3a0] handle() /my/super/secret/server/public_html/wp-content/plugins/amazon-associates-link-builder/vendor/a5hleyrich/wp-background-processing/classes/wp-background-process.php:177 [0x00007fc3dd41c330] maybe_handle() /my/super/secret/server/public_html/wp-includes/class-wp-hook.php:286 [0x00007fc3dd41c250] apply_filters() /my/super/secret/server/public_html/wp-includes/class-wp-hook.php:310 [0x00007fc3dd41c1e0] do_action() /my/super/secret/server/public_html/wp-includes/plugin.php:453 [0x00007fc3dd41c0e0] do_action() /my/super/secret/server/public_html/wp-admin/admin-ajax.php:114

    Apache access logs: [04/Feb/2019:06:26:24 +0000] "POST /wp-admin/admin-ajax.php?action=aalb_update_table&nonce=ea32cd6f3d HTTP/1.0" 200 439 "https://willstocks.co.uk/wp-admin/admin-ajax.php?action=aalb_update_table&nonce=ea32cd6f3d" "WordPress/5.0.3; https://willstocks.co.uk"

    Apache error logs: [Mon Feb 04 06:26:02.930398 2019] [proxy_fcgi:error] [pid 12251] [client 127.0.0.1:53407] AH01071: Got error 'PHP message: <h4>You are submitting requests too quickly. Please retry your requests at a slower rate. For more information, see <a href=http://docs.aws.amazon.com/AWSECommerceService/latest/DG/TroubleshootingApplications.html#efficiency-guidelines target=_blank>Efficiency Guidelines</a>.</h4>\nPHP message: <h4>You are submitting requests too quickly. Please retry your requests at a slower rate. For more information, see <a href=http://docs.aws.amazon.com/AWSECommerceService/latest/DG/TroubleshootingApplications.html#efficiency-guidelines target=_blank>Efficiency Guidelines</a>.</h4>\n

    nginx status logs: [04/Feb/2019:06:35:57 +0000] POST /wp-admin/admin-ajax.php?action=aalb_update_table&nonce=ea32cd6f3d HTTP/1.1 status_code:200

    Note: all IP’s and server names removed.

    • This reply was modified 5 months, 2 weeks ago by  Will Stocks. Reason: Formatting
    • This reply was modified 5 months, 2 weeks ago by  Will Stocks. Reason: Code formatting
    • This reply was modified 5 months, 2 weeks ago by  Will Stocks.

    I have also had to put together a fairly nasty function to strip out all of the scripts and styles that were being applied to the frontend of my site:

    function remove_aalb_frontend_bloat() {
    	if (!is_admin) {		
    		//Scripts
    		wp_dequeue_script ('handlebars_js');
    		wp_dequeue_script ('jquery-ui-tabs');
    		wp_dequeue_script ('thickbox');
    		wp_dequeue_script ('aalb_admin_js');
    		wp_dequeue_script ('aalb_credentials_js');
    		wp_dequeue_script ('aalb_sha2_js');
    		wp_dequeue_script ('codemirror_js');
    		wp_dequeue_script ('codemirror_mode_xml_js');
    		wp_dequeue_script ('codemirror_mode_css_js');
    		wp_dequeue_script ('codemirror_js');
    		//Styles
    		wp_dequeue_style ('jquery_ui_css');
    		wp_dequeue_style ('aalb_admin_css');
    		wp_dequeue_style ('font_awesome_css');
    		wp_dequeue_style ('thickbox');
    		wp_dequeue_style ('aalb_credentials_css');
    		wp_dequeue_style ('codemirror_css');
    		wp_dequeue_style ('aalb_basics_css');
    	}
    }

    I have now reverted to v1.8.0 and all error logging has stopped and frontend bloat has disappeared.

    @amazonlinkbuilder – are you able to confirm whether 1.9.1 fixes the above?

    Will Stocks

    (@willstockstech)

    @amazonlinkbuilder – are you able to confirm whether upgrading to 1.9.2 will resolve the above issues. The massive amount of logging bogged down my entire server resource, to the point I had to restart Apache, PHP and nginx!

    Everything seems OK to me at the moment, on 1.8.0 and I’m hesitant to upgrade 🙁

    I am using 1.9.2 and it is not working. I had to disable.

    Will Stocks

    (@willstockstech)

    Thanks for confirming @dschmidthawk – I will continue to wait it out for @amazonlinkbuilder‘s response then 🙁

    Will Stocks

    (@willstockstech)

    I can confirm – the issues still exist with 1.9.2 (I’ve moved hosting and have access to lower level logs).

    @amazonlinkbuilder – can you provide some sort of ETA for a fix please?

    I setup a fresh install of WordPress (and dupe of my site) on a domain that only I would hit/know. I’m getting rate limiting errors. Why am I hitting the rate limit with no traffic/no views on pages with Amazon products?!

    AALB also retains a steady level of CPU usage, which is strange… considering again no pages with products are being viewed/hit to justify needing the level of processing power it’s currently using (or outbound requests it’s making).

    I’ve reverted back to 1.8.0 and it has “somewhat” normalised, but is still consuming a steady and consistent 2% CPU minimum, and I’m still getting API throttling errors (again – no pageviews).

    If the API calls are to update product info, shouldn’t that be being doing via a _single_ cron job and updating all relevant products in a single call rather than multiple simultaneous calls out or high frequency cron jobs?

    The /wp-admin/admin-ajax.php?action=aalb_update_table&nonce=ea32cd6f3d confuses me because I’m not going anywhere near posts or the AALB plugin to justify this POST being made?

    It’s all very confusing! Lol!

    @amazonlinkbuilder – is there any info I can provide to assist with rectifying? My PHP skills are fairly limited but I will do what I can!!!!

    Will Stocks

    (@willstockstech)

    Added tags for 1.9.1 and 1.9.2 just for reference!

    @amazonlinkbuilder – are you able to advise any ETA at all? There are quite a few users that appear to be at a loss/have throttled accounts/are getting locked out.

    What do we do? Do we roll back to a previous version? Is there a new version close to release that fixes all of the issues people are seeing?

    Will Stocks

    (@willstockstech)

    @amazonlinkbuilder – are you able to advise at all please?

    I’m still seeing a large number of API errors being logged, upgrading to 1.9.0/1.9.1/1.9.2 makes the issues even worse and results in massive CPU resource consumption (massive number of (unnecessary?) API calls + DB updates/reads by the looks of it) which ultimately results in my server falling over!

    Is there a more “formal” support channel that I can contact to liaise/provide further details – via the associates dashboard there doesn’t seem to be anything? It seems that fundamental/core/major issue threads are going unanswered/ignored here whilst the “quick and easy” threads are getting quick responses and closed off 🙁 I understand that, trust me – I do… but even the slightest update would go a long way here.

    I’m not the only one facing these issues, per the following few threads that are similarly related:
    https://wordpress.org/support/topic/excessive-cpu-usage-2/
    https://wordpress.org/support/topic/you-are-submitting-requests-too-quickly-6/
    https://wordpress.org/support/topic/you-are-submitting-requests-too-quickly-please-retry/
    https://wordpress.org/support/topic/see-efficiency-guidelines/
    https://wordpress.org/support/topic/call-management-or-cache/
    https://wordpress.org/support/topic/submitting-requests-too-quickly-warning/

    Same for all?

    massive CPU resource consumption (massive number of (unnecessary?) API calls + DB

    New fix release?

    From new release for gutenberg my domain server alert me for massive CPU resource consumption.

    P.S.
    can you add a function to automatically delete all the plugin codes from all articles?

    Will Stocks

    (@willstockstech)

    @acronimo that is the general consensus in all of the existing threads since 1.9.2 (as well as the Plugin Rating comments) by the looks of it.

    Also, I have tried 1.9.2 on MULTIPLE different hosts (just to check), including: Managed Hosting, VPS, Shared Hosting, dedicated servers across multiple different hosting companies (AWS, DigitalOcean, Linode, Bluehost, SiteGround, Cloudways, 1&1 Hosting, GoDaddy and other hosting companies) and every single time, CPU usage goes through the roof (visualised through monitoring) or I get contacted about high CPU usage.

    I’ve tried across both PHP 7.2 and 7.3, Nginx and apache (and both combined)

    Really need @amazonlinkbuilder to offer some insight 😣

    Now they closed lots of threads, and sent us here, for some kind of solution? What is the solution? Rollback to a older version? Ok, I am going to give it a try, because this makes me so upset… 🙁 I can’t stop thinking on all the sales I probably lost and the time I invested making tests.

    Three months that the plugin started working less and less for me. I can’t search and the links and images don’t show most of the time.

    In the “official Amazon support” from Spain they sent me here to the forum, they have nothing to do with the plugin. But maybe I will try again, maybe with the German one. I still think they should not block their own plugin API connections.

    Will Stocks

    (@willstockstech)

    @taisa1984 – I’m running 1.8.0 and I’m still seeing API errors. Not only that, there’s no direct Gutenberg compatibility – you have to go through a lot of work to generate the shortcode and then add a shortcode block (which hasn’t always worked for me!)

    There’s no guaranteed support, which is very sad indeed! A lot of good people, reliant on this method of marketing, will have lost a lot of time and money – as well as risking their hosting company stopping their site altogether (some do for high CPU)

    @amazonlinkbuilder – we need some insight here 🙁

Viewing 15 replies - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.