Support » Plugin: WPSiteSync for Content » v1.4 issues

  • Resolved rkochis

    (@rkochis)


    I upgraded to v1.4 and now the sync widget is missing from all pages, and the bulk actions option is not showing up on the “Pages” area. Downgrading BACK TO 1.3.3 fixed the issue for me on multiple sites.

    WordPress 4.9.7, all plugins disabled for testing
    PHP 7.1.16
    Apache 2.4.28

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author ServerPress

    (@serverpress)

    Hello rkochis,

    Sorry to hear that you’re having trouble — and thanks for reporting this.

    So WPSiteSync is the only plugin running and you have this issue? What is the role of the user you’re using? In this release we added a new feature that allows you to set a minimum user role to be able to see the WPSiteSync UI and do Pushes. Please check your configuration and make sure that it includes your user’s role. That might be the issue.

    If it is not, we would like you to submit a help ticket on our contact page at https://serverpress.com/contact/ – we may need additional information in order to work on this with you and it’s better to do that in a more private channel.

    Again, thanks for letting us know about this. We’re looking into it and will look forward to your reply.

    All the best,
    ServerPress

    I had the same issue. Saving my WP Site Sync settings fixed it.

    Plugin Author ServerPress

    (@serverpress)

    Hi photocio,

    Thanks for adding to the conversation – and glad to hear that resolves the issue for you. We hope the same thing works for rkochis.

    When adding this feature, we did default the minimum role to ‘authors’, which should allow all roles that can create content. We’ll double check the code and make sure the default value is set up correctly.

    I save and save and save and destination is still without author 🙂

    Plugin Author ServerPress

    (@serverpress)

    Hi jaroslawistok,

    When you save the settings, are there any error messages at the top of the page? Or is the only message “Settings saved.”?

    Can you try setting it to something else besides “Authors”, such as “Admins Only”, save the settings, then select “Authors” again and save that. Does that allow you to set it “Authors”?

    I selected another minimum role and then saved settings, which brought back the widget for me.

    Unfortunately we use custom roles which are not supported so I have asked that they include an option to select from all valid roles.

    No errors ( I had to deactivate Shidify and other secirity plugins on destination due to errors)
    I try different combinations, Admin only, editors with slug or title, version match or not.
    Nothing works ;(

    Plugin Author ServerPress

    (@serverpress)

    @rkochis,

    Great. Glad that worked for you. We can work on the feature of allowing custom roles. That sounds like a great idea.

    @jaroslawistok,
    Can you submit a support ticket at https://serverpress.com/contact/ ? Looks like we’re going to need to get some more information from you in order to track down what the issue is.

    Many Thanks,
    ServerPress

    I just tested v 1.4.1 with the roles support and it works on my local dev environment running PHP 7.1.16 @64BitOS, however, there is an issue on our dev and prod environments running PHP 7.2.2 @64BitOS. WordPress 4.9.8 on all environments and same plugins on all 3.

    The issue is that the Roles settings are not getting saved. Once you click save the page shows “settings saved” but the new Roles checkboxes are no longer checked.

    Plugin Author ServerPress

    (@serverpress)

    Hi rkochis,

    Sorry to hear that you’re still struggling with this. Are you able to make other settings changes (Safe Mode, Delete options on uninstall, etc.) but just unable to make changes to the selected Roles?

    At this point I think the quickest way to resolve this is for you to submit a support request at https://serverpress.com/contact/ – We can get more information from you track your problem more easily that way.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘v1.4 issues’ is closed to new replies.