Support » Plugin: Asset CleanUp: Page Speed Booster » v1.3.5.9 causes WordFence Warnings

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Gabe Livan

    (@gabelivan)

    @mesmer7 Thank you for letting me know about this warning! Are you saying you can’t edit the post because of the error or it’s just annoying to keep seeing it? I hope the issue is not the former. That request is a standard WordPress call to /wp-admin/admin-ajax.php to check for the status (reachable or not) of the externally loaded CSS/JS (from other domain like a CDN, for instance: maxcdn.bootstrapcdn.com). If, for instance, the file returns a 400 Bad Request, then you know something is not right and you can either fix it or unload the file. It was added as a helper and so far, it has been working great.

    I have a suspicion that Wordfence blocks it because of the extra “wpacu_check_external_url” parameter added to the URL (as an easy way to distinguish it from other AJAX calls in case you check the console and you have lots of AJAX calls there, it can happen). This shouldn’t worry you at all if you know all your resources are loading fine. You can whitelist it and thus eliminate the error. Can you try that?

    I could edit the post. But the warning reoccurred with every edit. Very annoying. I was afraid to whitelist it because I’d never seen it before this week, and I didn’t know if it was a real security issue or not.

    I’ll reinstall the update later this evening, whitelist the issue, and let you know happens.

    Plugin Author Gabe Livan

    (@gabelivan)

    @mesmer7 how it’s going? Have you whitelisted the AJAX call in Wordfence? Let me know! Also, version 1.3.6.0 was just released. Consider updating the plugin as it comes with improvements and bug fixes.

    Yes, I whitelisted the ajax call, and it seems to have solved the issue. I was able to edit several posts last night without seeing the warning.

    However… When I go into the visitor logs, I still see something odd.

    My IP address tried to access /wp-content/plugins/wp-asset-clean-up/assets/sweetalert/sweetalert.css?ver=1 and received a 404 error. This must have happened when I was editing a post, because I never requested that URL. And I wasn’t redirected to the 404 page.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.