Support » Plugin: WooCommerce Shipping & Tax » v1.25.10 includes PHP 7 syntax, but states a requirement of PHP >= 5.3

  • Resolved Q

    (@quinncom)


    After updating to version 1.25.10 of the WooCommerce Shipping & Tax plugin, one of our sites has this error:

    PHP Parse error: syntax error, unexpected ':', expecting ';' or '{' in /var/www/html/wp-content/plugins/woocommerce-services/classes/class-wc-connect-shipping-label.php on line 323

    At this line of the file, it contains this code:

    public function is_order_eligible_for_shipping_label_creation( WC_Order $order ): bool {

    This function definition contains a return type declaration of bool. This form of return type declaration is only supported by PHP >= 7.0. However, this plugin has a requirement of: Requires PHP: 5.3 which allows the plugin to be installed and auto-update on WP installations using PHP versions < 7.0.

    • This topic was modified 8 months, 2 weeks ago by Q.
Viewing 4 replies - 1 through 4 (of 4 total)
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘v1.25.10 includes PHP 7 syntax, but states a requirement of PHP >= 5.3’ is closed to new replies.