Support » Plugin: Crop-Thumbnails » v1.2 local not working

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter koentjuh1

    (@koentjuh1)

    More info:

    Console images:
    https://ibb.co/W27zc5q
    https://ibb.co/mttqPcT

    Thanks for your time,

    Regards Koen

    Plugin Author Volkmar Kantor

    (@volkmar-kantor)

    hi,
    i got this problem to when i first tested the plugin on wordpress v5. But it seems this had to do with wordpress (maybe with the admin_ajax function).

    I made a clean install of wp v5, after that i got no problems. Maybe deleting wp-admin and wp-includes and restore with the new folders solve the problem. Let me know.

    Hi,

    I was having the same problem. Same error in the same place. I’m running WP 5.0.1 and Crop Thumbnails 1.2.1.

    If I output the response (data) from the fail()-bracket it says:

    Deprecated: Non-static method CropPostThumbnailsEditor::fixJsLangStrings() should not be called statically in <b>/home/XXXXXX/public_html/wp-content/plugins/crop-thumbnails/functions/editor.php</b> on line 63

    The same error is found on many lines of code in that file.

    What I did was simply make the function “fixJsLangStrings()” static, by changing:

    protected function fixJsLangStrings($msg) {
        return str_replace('&quot;','"',esc_js($msg));
    }

    To:

    protected static function fixJsLangStrings($msg) {
        return str_replace('&quot;','"',esc_js($msg));
    }

    In functions/editor.php

    It is working fine now. Maybe this is something you should change in the plugin code. Otherwise my change will be overwritten when a new version is released 😉

    • This reply was modified 2 years, 10 months ago by ericjohansson.
    Plugin Author Volkmar Kantor

    (@volkmar-kantor)

    Hi ericjohansson,
    thanks for investigate this. I fixed the bug and rolled out version 1.2.2.

    Ciao Volkmar

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘v1.2 local not working’ is closed to new replies.