Support » Plugin: Heartbeat Control » v1.2: How do you set the frequency on

  • Hello,

    I just updated to v1.2 and started with a new rule.

    I set the behaviour to Modify heartbeat and the Frequency appears as 0 with no way of setting it.

    I then click ‘Save Changes’ and the Frequency changes to 15 for the same rule, but again there is no way of setting it.

    How do you set the frequency for rules with v1.2 ?

    Thank you,

    Bharat

Viewing 4 replies - 16 through 19 (of 19 total)
  • @bahead,

    The closes code I can find to yours is…

    <div class="cmb-row cmb-type-slider cmb2-id-rules-0-heartbeat-control-frequency cmb-repeat-group-field heartbeat_frequency" data-fieldtype="slider">

    ..and this does not have the style tag, and I don’t know why it’s different if you are using the same version of the plugin.

    @jeffmatson is probably the best person to look into this.

    bahead

    (@bahead)

    @bharatk Yes, I said the “generated code”. Some other code is hiding the slider. My guess is the maybeHideFrequency function in bundle.js, but why this is happening only for me (apparently) is probably a collision with some other jquery plugin I have installed, which I suspect is what @jeffmatson will suggest. I don’t have the time to troubleshoot, so for the time being I’ll just manually display the slider to make the adjustment. Or I’ll revert to the previous version.

    Plugin Author JeffMatson

    (@jeffmatson)

    @bahead Could you post a lit of the plugins you’re running? Have you tried deactivating/reactivating other plugins one-by-one to see if you can locate which plugin is causing the conflict?

    bahead

    (@bahead)

    @jeffmatson I think I’ve isolated the problem. If I disable line 30 in settings.php:

    wp_register_style( 'slider_ui', '//cdnjs.cloudflare.com/ajax/libs/jqueryui/1.12.1/themes/smoothness/jquery-ui.min.css', array(), '1.0' );

    the slider appears. I have at least one other plugin already using jquery-ui.min.css. A quick search shows Contact Form 7 is already loading it.

    I have not tested the impact of disabling line 30 but I can confirm that doing so displays the slider and allows me to adjust the setting.

    • This reply was modified 9 months ago by  bahead.
Viewing 4 replies - 16 through 19 (of 19 total)
  • The topic ‘v1.2: How do you set the frequency on’ is closed to new replies.