Support » Plugin: QuizMaster » v0.6.1 Released

  • ResolvedPlugin Author goldhat

    (@goldhat)


    QuizMaster v0.6.1 is now released and served from this WordPress.org directory. The update eases the requirement on ACF Pro by providing the option to utilize the free FieldMaster plugin hosted at GitHub. It is a stable fork of ACF Pro and will provide the fields, we recommend it over ACF Pro as FieldMaster will also be actively developed and add substantial improvement to the existing ACF codebase.

    This is the first release where all output of the front-end quiz is handled via templates that can be overridden at the theme layer. Our earlier version were at best 80% coverage of the transition from “Views” output function to templates that can be themed.

    We’ve also added better support for QuizMaster Extensions, and 3 extensions have developed and approved for hosting here at WordPress.org, we are working on finalizing the releases of those. This batch extension release will include QuizMaster Progress Bar, QuizMaster Grades, and QuizMaster Audio. More details in the Development Updates thread and other posts about QuizMaster Extensions.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi,

    This really a good idea to continue the previous work of my favorite WP Quiz Pro plugin. And other your extensions are very promising. Especially Quizmaster Audio.

    The main problem is that I can not install the plugin because of “QuizMaster requires either FieldMaster (Free Fields Plugin, download latest release at …”

    I have installed the FieldMaster and still not able to install the Quizmaster plugin.

    Thanks

    Plugin Author goldhat

    (@goldhat)

    Is it possible that when you installed fieldmaster that there is a version number in the main plugin directory, something like “fieldmaster-v0.0.1” instead of “fieldmaster”? This would break the activation check which tests specifically for “fieldmaster” being installed. GitHub serves the folders zipped with release number, so it’s necessary to change the main plugin directory before activation to “fieldmaster”.

    Please check that, and if the problem persists let me know but that check usually works so long as fieldmaster (or ACF Pro) are in place and activated.

    Plugin Author goldhat

    (@goldhat)

    Sidenote on this we’d love to get FieldMaster into WordPress.org plugin directory so it can be more easily installed and also used by more plugins and themes as a field integration platform. What is stopping that currently is that it contains code from ACF Pro and that is blocked from being in the WP directory (the original ACF plugin author does not support any forking or distribution of that code). We’ll have to rewrite key components of ACF Pro, namely the repeater field to make a version that will meet hosting requirements. If anybody reading this can help support us in that effort with donations of time or funding let us know, we can be reached through our site at goldhat.ca. Thanks.

    Hello @goldhat,

    Yes, you are right the name of the plugin folder ‘fieldmaster-master’ has been renamed ‘fieldmaster’ and the issue has finally been fixed. And no problem at all with the Quizmaster installation. 🙂

    Thank you

    Plugin Author goldhat

    (@goldhat)

    Good to hear that fixed it, someday hope we can get FieldMaster approved for hosting because then we’d also embed it into QuizMaster so it’s a single plugin.

    Plugin Author goldhat

    (@goldhat)

    Marking resolved, for anybody scanning over this solution to issue is to ensure FieldMaster plugin main directory is named “fieldmaster”, removing any version numbers.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.