Support » Plugin: Fast Velocity Minify » v.3.2.4 /combined url not found

  • Resolved Daniel

    (@saddeveloper)


    Hi! After updating to ver. 3.2.4 CSS combining stopped working at all. It returns “GET http://example.com/combined net::ERR_ABORTED 404 (Not Found)” error even with standard TwentyTwentyOne theme and no other plugins active. This is WP 5.9, PHP ver. 8.
    It also has once returned the following error. But I am not sure whether this warning happened before or after the update, because it happened only once (I see you have addressed it i another request).

    PHP Fatal error:  Uncaught Error: Undefined constant "FS_CHMOD_FILE" in /wp-admin/includes/class-wp-filesystem-direct.php:164
    Stack trace:
    #0 /wp-admin/includes/class-wp-filesystem-direct.php(86): WP_Filesystem_Direct->chmod()
    #1 /wp-content/plugins/fast-velocity-minify/inc/common.php(472): WP_Filesystem_Direct->put_contents()
    #2 /wp-content/plugins/fast-velocity-minify/inc/frontend.php(437): fvm_generate_min_url()
    #3 [internal function]: fvm_process_page()
    #4 /wp-includes/functions.php(5212): ob_end_flush()
    #5 /wp-includes/class-wp-hook.php(307): wp_ob_end_flush_all()
    #6 /wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
    #7 /wp-includes/plugin.php(474): WP_Hook->do_action()
    #8 /wp-includes/load.php(1100): do_action()
    #9 [internal function]: shutdown_action_hook()
    #10 {main} thrown in /wp-admin/includes/class-wp-filesystem-direct.php on line 164

    As soon as I downgrade to ver. 3.2.2, everything starts working fine again.
    Plugin settings:
    https://ibb.co/Fnx1HrP
    https://ibb.co/hmhwFbN
    https://ibb.co/B4qXwx4

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Raul P.

    (@alignak)

    If you are seeing <link rel="stylesheet" href="combined" media="all" /> I just tested and I can confirm, this happens when there are no write permissions on the cache directory. Please ensure the /wp-content/cache/ directory exists and it’s writeable by the PHP user.

    If it’s not this, then it seems to me, that your server has some cache that needs to be purged, or maybe some file disk permissions, but can you please check the following.

    a) Purge Minified CSS/JS files instantly – is disabled

    b) the directory under /wp-content/cache/ exists, and it’s writeable.

    c) you have purged the cache on FVM, followed by any other cache plugin or your hosting cache (you may need to log in to their control panel, depending on your provider)

    d) open chrome in incognito mode, then “view source” and check what is the name of the combined css file name, and it’s location. Note the first digits on the file name. It should look like this: https://yoursite.com/wp-content/cache/fvm/min/1643713442-css415aa84a8178f2faa1874f311cf5818bebda56ed4448886c2af4fbba57038.css

    e) visit the url and see if it opens or returns a 404 error. if it shows 404, check on the /wp-content/cache/fvm/min/ directory (some file manager, sftp, hosting, etc) if the file actually exists and it just doesn’t open, or if it doesn’t exist.

    Now, if the file exists but it returns a 404, something is wrong because the server is blocking the file from showing. If it does not physically exist, keep reading.

    f) Purge everything on FVM, via wp-admin top admin bar, FVM > Purge All

    g) refresh the incognito chrome window and view source again. Then compare the css file name, specifically, the first digits to see if it’s the same, or if it has changed.
    Note that the filename digits, are supposed to change whenever you purge FVM cache.

    If you are here, then there are two possibilities.

    1) If the number on the css file name did not change after purging FVM, that means you are seeing a cached version of your html page, so naturally, it’s still pointing to an older file that may or may not be deleted.

    This means, FVM is not capable of clearing the page cache either for some other cache plugin that is in use, or for your hosting caching, or perhaps some other third party cache like cloudflare APO for example.

    This would also cause your “css files to disappear”, though what happened there, is the fvm cache was purged after the upgrade but the page cache is still pointing to the old files, now deleted.

    Purge Minified CSS/JS files instantly, option can be disabled and cache files will be preserved for 7 days. This allows for any third party caches to expire, provided their expire date is not longer than 7 days. Most hosts have this set to 15 minutes or so, so this is enough.

    2) If the digits on the file name changed after purging FVM, check if the file opens on the browser. If it returns 404, and if the file still doesn’t exist physically, then it means the plugin is not able to save the file on the cache directory.

    In that case, I need to know.

    Does your wp-config.php configuration require you to use ftp credentials to be able to write files, or are you perhaps using something like the s3 offload plugin, which uploads files to amazon s3 instead of allowing files to be written to the server?

    The PHP Fatal error is caused by a core file, that is included on the plugin to allow writing of the cache files. This file however, no longer exists on the latest version update, so it shouldn’t be showing.

    Please take note of your settings, try to delete the plugin and reinstall again.

    Sometimes servers and certain hosting providers have object cache enabled, or file storage cache… and what this does is to cache code execution in memory to speed things up, so there is a possibility sometimes right after the update, the server is still processing code from the previous version even if the files are already different.

    Object cache, as well as any other file cache system should be purged, anytime you do an update, being that a wordpress core update, theme or any other plugin.

    Most hosting providers that have page caching, have a place where you can go and purge everything, but in doubt, please ask your hosting about cache purging.

    I just retested yet again, reinstalling a fresh WP 5.9 with PHP 8 on 2 different providers, installed FVM, enabled css merging, and it’s working properly.

    My wordpress files have the same permissions and ownership as the php user (the most common setup), so wordpress can write files directly. It does not require ftp credentials or anything else.

    If you run PHP as a different user than the files owership, perhaps that could be the reason… but untested on my end, so please let me know.

    Hope this helps.

    Duke Yin

    (@freeduke)

    Same issues here, 2 sites were destroyed by this plugin yesterday.

    Hey @alignak you would rather write this much reply, why wouldn’t you just test on more environments and fix this deadly issue of your plugin?

    Thread Starter Daniel

    (@saddeveloper)

    Hi! Wow, thank you for such a detailed reply!) I am afraid this issue hardly can be related to some server peculiarity: the thing is that, as a WP developer, I am assisting lots of users. And all of them are hosted on different hostings, while having the same problem after the last plugin update. Nevertheless, I have followed all the steps above.
    Purge Minified CSS/JS files instantly – Disabled.
    The /wp-content/cache/ folder does exist and is writable. I made sure ver. 3.2.2 is able to write new CSS files there when I downgrade – you can check, the CSS files have different names: https://ibb.co/q1xjmWx vs https://ibb.co/F3MSfNG
    My hosting does not have server-side caching. Neither I have any CDN, Cloudflare, etc. or other cache plugins active. And I always launch a new incognito window, with disabled cache in the inspector https://ibb.co/WpHz0M0
    As soon as I update to ver. 3.2.4 again, files from /wp-content/cache/ no longer load https://ibb.co/PhXyFwq As soon as I downgrade to ver. 3.2.2 – the files are loaded fine. I have tried it numerous times.
    I have tried to install the plugin from scratch and noticed the following database error which shows up after plugin installation:

    Deletion failed: WordPress database error: [Table 'u162501544_n5daY.wp1_fvm_cache' doesn't exist]TRUNCATE TABLE wp1_fvm_cacheWordPress database error: [Table 'u162501544_n5daY.wp1_fvm_logs' doesn't exist]TRUNCATE TABLE wp1_fvm_logs{"success":true,"data":{"delete":"plugin","slug":"fast-velocity-minify","plugin":"fast-velocity-minify\/fvm.php","pluginName":"Fast Velocity Minify"}}

    Again, I should emphasize the problem happens to numerous users on different hosting, I am assisting to.
    Thank you so much for your help!

    • This reply was modified 8 months ago by Daniel.
    AMIB

    (@amib)

    The previous version was working properly and there was no write permissions related problem.

    Today I did open more than 30 sites to disable Merge functionality

    Plugin Author Raul P.

    (@alignak)

    @freeduke sorry about that, but please always test (any) plugin before updating.
    @saddeveloper the information you have provided was very helpful, thanks a lot. I believe v3.2.5 should work now for your environment type.

    Thread Starter Daniel

    (@saddeveloper)

    With v3.2.5 it works fine, indeed. Thank you for fixing it so quickly!

    Thread Starter Daniel

    (@saddeveloper)

    Closing thread …

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘v.3.2.4 /combined url not found’ is closed to new replies.