Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » V 2.6.3 break the Justified Grid layout

  • Resolved pako69

    (@pako69)


    Hi

    Here a video where I show you this bug: https://share.getcloudapp.com/xQuYJQQg

    The first thing you will see is a page where the layout is ok with the previous version of your plugin, next you will see the same pahe where the layout is totaly broken with a big image…

    Where I can download the previous previous version please ? I can not publish any moore posts…

    Thanks

Viewing 15 replies - 1 through 15 (of 24 total)
  • Thread Starter pako69

    (@pako69)

    I found your 2.6.2 version and installed it and everything is working like before, so there is a bug with the 2.6.3, I suspect “Switched the Justified Grid layout to use CSS when image sizes are available.” to be the culprit…
    Thanks

    Plugin Author Sayontan

    (@sayontan)

    I looked at the screencast, and this seems more a problem with the zooming behaviour rather than the CSS layout itself – your layout by itself is not distorted.

    Typically when I introduce something drastically new, I provide a way to use the old behaviour in case people face unexpected breakage. In this case you can switch to the JS layout using the layout_engine option. But that is unlikely to fix the issue, so you can temporarily disable the “zooming” behaviour from Photonic → Settings → Generic Options → Layouts → Random Justified Gallery – Thumbnail Effect.

    I will patch the issue over the weekend.

    a similar problem, the alignment stopped working

    Pic

    Plugin Author Sayontan

    (@sayontan)

    @morguss,
    I cannot access the link you have posted. Please provide a working link where the problem exists.

    Plugin Author Sayontan

    (@sayontan)

    I am not seeing an issue. What are you expecting? Do you want the last image to fill the entire row? With CSS-based layouts that sometimes becomes challenging because your last photo will appear to be huge.

    Please follow the advice I have provided in the previous post if you want to switch to the JS-based rendering – that will help align the last row to the rest of the rows. You can do so from one of two places as documented:

    1. Either globally set Photonic to use JS from Photonic → Settings → Google Photos → Google Photos Settings → Layout Processing Mode
    2. … Or set it at an individual gallery level by using the layout_engine='js' shortcode attribute or the “Gallery layout processing mode” option in the Gallery Wizard.
    Thread Starter pako69

    (@pako69)

    Hi @sayontan

    I tried your 2.6.4 update but it still do not work for my justified gallery

    Before (V 2.6.2) > 3 images in a same row > https://i.postimg.cc/hPr7Gznv/photonic-ok.jpg

    Now (V 2.6.4) > The same 3 images and a bigger one : https://i.postimg.cc/GmmTTL3Q/photonic-not-ok.jpg

    Thanks

    Plugin Author Sayontan

    (@sayontan)

    I tried your 2.6.4 update but it still do not work for my justified gallery

    Before (V 2.6.2) > 3 images in a same row > https://i.postimg.cc/hPr7Gznv/photonic-ok.jpg

    Now (V 2.6.4) > The same 3 images and a bigger one : https://i.postimg.cc/GmmTTL3Q/photonic-not-ok.jpg

    It is working fine – that is the expected behaviour. Both your galleries are justified grids. It is just that the distribution of your images is different.

    In any case, if you prefer the JavaScript-based layout, you can use one of the two options I have documented above.

    Thread Starter pako69

    (@pako69)

    Sorry but with version 2.6.2 I have 3 perfectly aligned on a single row and with version 2.6.4 it render 2 images in a first row and a very big one under the first 2 images.

    > The screenshot I gave you here https://postimg.cc/rK7wvLr0 do not show you the full page, I do not have capture the whole screen, but the third image is much, muche higher in height!

    And using the JS Layout engine is not possible: I can’t modify on hundred shortcode galeries…

    It was running perfect before… 🙂

    • This reply was modified 1 month, 2 weeks ago by pako69.
    Plugin Author Sayontan

    (@sayontan)

    @pako69,
    Have you tried using the JS engine as I have suggested in my 3 posts above?

    Thread Starter pako69

    (@pako69)

    @sayontan

    No. But even it it works it supposed to change all the shortcodes already used.
    this is not possible…

    Somthing changed in this new version, I don’t know what, but it was just percect before 🙂

    Plugin Author Sayontan

    (@sayontan)

    No. But even it it works it supposed to change all the shortcodes already used.
    this is not possible…

    No – please read through the documentation again. You can change this globally, without changing each shortcode individually. Depending on which platform you are using, you just need to set one option: Photonic → Settings → <Platform> → <Platform> Settings → Layout Processing Mode. Just changing a single option will change it for all your galleries without changing any shortcode.

    Thread Starter pako69

    (@pako69)

    Ok but I do not use any plateform I just use Native WP Galleries

    Plugin Author Sayontan

    (@sayontan)

    For native WP galleries the option is under Photonic → Settings → Generic Options → Native WP Galleries.

    Thread Starter pako69

    (@pako69)

    I dot not have this in Photonic → Settings → Generic Options → Native WP Galleries but maybe it’s only available in 2.6.4 version ?

Viewing 15 replies - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.