Support » Fixing WordPress » uwanted index.html

  • Resolved rdmckelvey

    (@rdmckelvey)


    My client has been managing a site I built about a year and a half ago. We now are experiencing a problem with the site URLs (and permalinks?).

    All the URLs of the site now have an /index.html/ between the domain name and the page/post name (e.g https://www.menokin.org/index.html/ for the home page).

    I see that in the settings>general panel the Site Address (URL) is set to https://www.menokin.org/index-html, but if I edit this to omit the /index.html, I get a “www.menokin.org redirected you too many times” error from Chrome and no home page.

    Resaving the permalinks has no effect.

    Obviously, we’d like to get rid of the /index.htm/ in the URLS, but how?

    Thanks

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator t-p

    (@t-p)

    If you want to chnage the URL, use FTP/ SFTP , or your web-host’s cPanel or whatever file management application your host provides, access phpMyAdmin on your host, then find your DB, there check the wp_options Table (Note: The table prefix of wp_ may be different if you changed it when installing), and make sure siteurl field and home field are correct. See https://codex.wordpress.org/Changing_The_Site_URL#Changing_the_URL_directly_in_the_database

    If you haven’t already done, always backup your database before doing any actions, just in case something really goes wrong. You can never have enough backups!

    Thread Starter rdmckelvey

    (@rdmckelvey)

    t-p,
    Thank you for providing this advice. Unfortunately, it doesn’t seem to be the answer. If I go to phpMyAdmin and the options table, I see the “home” entry is “https://www.menokin.org/index.html” It clearly should be set to simply “https://www.menokin.org”. However, if I edit the field to that, I get what I reported previously, a “too many redirects” message from Chrome (obviously some sort of infinite loop?).
    If I go to the WordPress dashboard and change the home (Site Address) field there, it changes the entry in the options table in the process (not surprisingly). It doesn’t seem to make a difference if I edit this table entry manually in cpanel, or through WordPress settings. The result is the same.

    I don’t understand why the path, http://www.menokin.org/index.html/ seems to point to the root of the site instead of just the domain name…?

    Thanks again!

    Thread Starter rdmckelvey

    (@rdmckelvey)

    Just to close this discussion out, I’ve solved my problem. It turns out my client had set up the Site Address to include “index.html” but had also gone to the BlueHost dashboard and set up a redirect to that address. I was completely unaware of the latter.

    All is well.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘uwanted index.html’ is closed to new replies.