Support » Installing WordPress » utf8_decode error on install? … on line 113

  • plainsman

    (@plainsman)


    Well, bummer. I’ve encountered errors this time. I have never encountered errors before installing WP. 🙁 I’ve searched, but not found explanations that help. Any help will be appreciated.
    On clicking the ‘Step 3’ button, I receive this message:

    Fatal error: Call to undefined function: utf8_decode() in /htdocs/www/wp-includes/functions-formatting.php on line 113

    I go straight to the site and see that it created the tables, but … Then, there is this:

    Database error: [Table ‘heshe.wp_post2cat’ doesn’t exist]
    SELECT DISTINCT ID, category_id, cat_name, category_nicename, category_description, category_parent FROM wp_categories, wp_post2cat, wp_posts WHERE category_id = cat_ID AND post_id = ID AND post_id IN (1)
    Warning: Invalid argument supplied for foreach() in /htdocs/www/wp-blog-header.php on line 478

    I’ve done this twice. Deleted tables. Done it again. Same problem. Re-uploaded files, etc.
    Any ideas? I’m already running one WP blog on these servers and didn’t encounter any problems with that install. But, they have ‘redone’ their servers since then.
    Because of the “utf8_decode” in the error … I note, in my Control Panel for ‘extensions’, that I have these options.
    Should one be turned on?

    Language and Character Sets
    ctype Character type functions
    iconv Character set conversion functions
    gettext Native language support
    mbstring Multi-byte string functions
    pspell Spellchecking functions
    recode Character set conversion functions

    None of them are ‘ticked’ – or turned on.
    Sorry for the long post. Just trying to cover all the bases.
    Thanks.

  • The topic ‘utf8_decode error on install? … on line 113’ is closed to new replies.