Support » Fixing WordPress » UTF-8 and the visual editor

  • Okay, here is a pretty weird problem, one that is more than a little annoying.

    If write a new post using the visual editor, when the post is added to the database, it is encoded in a UTF-8 format. Specifically, a different character is used to represent a double space after a period.

    If I write the same post using the old style code editor, it does not write out UTF-8 characters for the double space.

    Now, this is where it gets weird: If I pull the RSS feed for that site, both posts in theory will be encoded in UTF-8, but the post made with the visual editor will in fact have full UTF-8 encoded characters in the post description or content areas, while the post written with the code editor will not. Some blog 2 blog programs and feed readers will see double characters in the first post, but read the second post correctly.

    Essentially, it is as if the posts made with the visual editor are getting UTF-8 encoded twice, once on posting, and a second time when being displayed in the RSS feed.

    Is there any way to make the posts as they appear in the RSS feed the same (unencoded, unless I specifically request it)? If I change the UTF-8 to LATIN-1 in the discussion area, it breaks the posts are they appear on the blog. Why are these two areas controlled by a single setting?

    Any ideas?

Viewing 5 replies - 1 through 5 (of 5 total)
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘UTF-8 and the visual editor’ is closed to new replies.