Support » Fixing WordPress » UTC time wrong

  • Resolved Emily

    (@cleanup)



    Greetings! I have one hair left due to this issue. No matter what I do, I can’t get the UTC time to set correctly.

    We have our hosting with MediaTemple on a DV server. We are using WordPress multisite, though it does the same thing with a regular WordPress installation, clean with no plugins or themes installed.

    We’re in the eastern US time zone, but the time shown in WordPress settings never changes even when I set the timezone in Plesk and restart Apache. No matter what changes I make to the timezone in Plesk, WordPress does not change, it keeps reporting the same thing. I’ve also tried setting UTC time zone in php.ini and it has no effect at all. The time is reported correctly in UTC when I use the “uptime” command on the server.

    Right now, it’s 2:56pm here in Florida. I have WordPress set to UTC time zone. And it reports this on the settings page:
    Universal time (UTC) is 2017-01-06 14:56:02

    UTC should be 19:56.

    I have asked MediaTemple support multiple times for help and they have not been able to assist. It’s messing up the cron schedule in WordPress and making it so we can’t schedule posts. Yes, I know I can get a plugin to fix that but I want to fix the underlying problem.

    What else can I check or do to correct this?

    Thank you!

Viewing 5 replies - 31 through 35 (of 35 total)
  • @otto It’s more simple than that – Everyone not using Mediatemple DV hosting is not having the issue Emily and I were having, so whatever goes wrong for them does not belong in this topic.

    But as usual, everyone with a wrong time setting somehow has the same issue in their perception… 😉

    The problem has been resolved by Mediatemple. And this has been confirmed by Emily and me. Issue solved, topic can be closed.

    And thank you to all who contributed. It’s very helpful to get assistance in narrowing down the problem so I know what to show and tell support so they can fix it!

    • This reply was modified 1 year, 9 months ago by  Emily.

    I not use Mediatemplate DV but Host Europe. I had the same problem.

    My hoster could solve it, after I had sent him the link to this discussion.

    My hoster has said:

    The reinstallation of tzdata in CentOS has fixed the problem.
    Why the reinstallation of an absolutely identical package corrected the delivery of UTC in PHP is completely unclear.

    However, since several CentOS systems (at least your system and that from the linked forum) are affected, I think that is a general bug in CentOS 7.

    Mediatemple also uses CentOS on many DV so that makes sense 🙂

    I can confirm that:

    yum reinstall tzdata

    Followed by:

    systemctl restart httpd

    solved the issue for me as well. Running on CentOS 7.

Viewing 5 replies - 31 through 35 (of 35 total)
  • The topic ‘UTC time wrong’ is closed to new replies.