WordPress.org

Support

Support » How-To and Troubleshooting » Using WP for the whole site instead of just one directory

Using WP for the whole site instead of just one directory

  • Hi,

    I tried to search for equivalent threads but didn’t manage to find any quite alike, so here goes.

    Here’s the deal: I got my WordPress with K2 installed in http://mydomain/blog/ directory. Now I’d like to use WP&K2 for the whole site, so that there would be a static front page at the domain root, the blog would still be in the /blog directory, and there could be additional pages like /about, /cv etc. You get the idea. I’d also like to have an uniform navigation for the whole site using the K2’s great main menu navigation.

    Basically it’s Giving WP its own directory the other way round.

    Is there maybe a howto for this somewhere, or could you give me some pointers how to get started?

    Thanks in advance!

Viewing 14 replies - 1 through 14 (of 14 total)
  • No – it IS Giving WP its own directory.
    You do like it says in the codex exactly.
    Then go to admin -> Options -> Reading and assign (or make one first) a page as a static front page.
    Everything will work as desired.

    OK, so I won’t have to do it like described here?

    No – definitely not from the scenario you posted about.

    I’ll try that tomorrow and post back how it worked out.

    Thanks for your advice!

    Well, I didn’t have the patience to wait until tomorrow so I decided to give it a go right away. I did as instructed in the codex and in your post. Now I have the front page at the root of my domain, but there’s no navigation button for the blog, and when trying to enter the /blog directory manually, it returns the WP 404 page.

    Give up a link. That’s a fairly basic set up.

    The blog is at http://roju.org/blogi/ (completely in Finnish so far, sorry about that).

    Looks like you did it backwards?
    index.php should be in root and all other files in /blogi.

    Yeah well I did a rollback to the last setup that worked, and that’s the case now. I think I did everything as instructed. I’ll try it again at some point.

    Did the last line in your index.php that you put in root look like this?
    require('./blogi/wp-blog-header.php');

    Yes, I changed that too.

    I would be willing to look at it if you want. I’m on the Install4free team.
    If so, click on my name and use the contact link at top of page. Send me your ftp info (user/pass) and blog info (user/pass).

    Done.

    BTW, I’ve thought of reinstalling WP and doing some cleaning up in general. So if you don’t have the time or motivation to try and fix my blog for me, that’s OK too.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Using WP for the whole site instead of just one directory’ is closed to new replies.
Skip to toolbar