WordPress.org

Support

Support » Localhost Installs » [Resolved] Using Wamp, new pages get 404 "requested URL not found on this server"

[Resolved] Using Wamp, new pages get 404 "requested URL not found on this server"

  • Hi
    I am running Wamp. Each time I create a new static page, the link appears on the menu bar of my homepage but, when clicked om, the new page can’t be found.

    I created a page called More with sample text, clicked on the link on my homepage and a got the message:

    Not Found

    The requested URL /wordpress/more/ was not found on this server.

    The preview was fine but once published, any new page comes up with a 404 error.

    I’m new to WordPress and would appreciate any help.

    Thanks

    Brian

Viewing 15 replies - 1 through 15 (of 17 total)
  • /wordpress/more/ was not found on this server.

    You probably don’t have mod_rewrite working. If you change the default WordPress permalinks and it’s not working, your URL’s will 404.

    Pretty permalinks on WAMP: Click on the green WampServer icon in the system tray, select Apache > Apache modules > then scroll down the module list until you come to “rewrite_module”, and place a check mark next to it. See if that makes the difference. You may need to restart apache for the changes to take effect.

    Hi, ClaytonJames

    Spot on!

    Put the tick in place and the pages come up exactly as they should.

    Thanks!

    Brian

    You’re welcome!

    Just wanted to add that this worked for me too. Great to get a nice clear answer! Thankyou

    +1 Helped end my frustration CJ, thanks!

    Clayton! Very on-point! Thanks a mil!

    Thanks Clayton,… It worked for me too.. Your awesome

    Awesome Clayton, I love forums

    THANK YOU SOOOOOOO MUCH. Something so simple but if you don’t know it just don’t know it. Thanks

    thank you!

    hey guys I am new to WP, i have the same error, is the same if I use MAMP?

    because i can’t find the “rewrite_module”..

    Blood pressure up … blood pressure back down. Thanks for the fix! 🙂

    Clayton – thank you sir!, One moment of kindness continues to pay off for so many.

    Did I already say thanks?

    Hello, so glad so many have found their answer!

    However, when I follow the above directions, it results in all my links now taking me to the WampServer Server Configuration page :/

    I did restart Apache.

    Any ideas on a fix?

    Oops, sorry for not starting my own topic, but I’ve discovered the issue:

    If you have changed your WordPress url, and put a “/” at the end, it results in the behavior of pointing all your WordPress links to the localhost root. I just removed the “/” and all was good!

    Hope it helps someone, sure is frustrating not finding answers! O.o

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘[Resolved] Using Wamp, new pages get 404 "requested URL not found on this server"’ is closed to new replies.