Support » Plugin: WooCommerce Google Analytics Integration » using UA and GA-4 simultaneously

  • Resolved Megunticook

    (@megunticook)


    Is it possible to configure the Global Site Tag to send data to a UA and GA-4 property simultaneously?

    Your plugin documentation includes a PHP function which I think does this but wanted to be sure I understand it.

    Right now I have the Google Analytics Tracking ID set to the UA property. Can I use that function to add the GA-4 tracking ID to the code generated by the plugin?

    Or do I need to use the GA-4 ID in the plugin settings and then add the UA property using the PHP function?

    Thanks…I’m thinking it doesn’t matter which tracking code goes where but just wanted to check.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter Megunticook

    (@megunticook)

    Update: I tried this on my dev site, using the UA ID in the plugin settings and adding the GA-4 ID with the PHP function. Am seeing the GA-4 ID now appended to the tracking code. Duplicated on production site, nothing showing in the GA-4 “Realtime” when I browse the site (I’m not logged in) but maybe just need to wait a day or so.

    Please offer any suggestions, affirmation, etc. I’m going to hold off on marking this as resolved until I verify that the data is showing up in GA-4.

    • This reply was modified 1 year, 1 month ago by Megunticook.
    Plugin Support Doug – a11n

    (@dougaitken)

    Automattic Happiness Engineer

    Hey @megunticook

    This could be possible but it would involve code custom that we don’t offer support for.

    Your plugin documentation includes a PHP function which I think does this but wanted to be sure I understand it.

    Can you link me to the section you’re using so I can ensure there is the correct caveat added that support for customizations isn’t available.

    Thanks,

    @megunticook I can confirm the function works. 😉 Maybe you need to clear your cache?
    @dougaitken You can find the function here in the plugin’s documentation.

    Plugin Support Thu P. a11n

    (@thup90)

    Thanks for sharing the doc @michieldoetjes

    Hi @megunticook,

    Clearing cache is a good suggestion. As mentioned in our documentation, this is outside of our scope of support, I’d recommend getting in touch with a developer if you still need help with this.

    Thread Starter Megunticook

    (@megunticook)

    All set–I think there was just a delay on Google’s end. Thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘using UA and GA-4 simultaneously’ is closed to new replies.