Support » Plugin: Customer Reviews for WooCommerce » Using Trustbadge shortcode

  • Resolved kmam

    (@kmammasis)


    Hello,

    I am trying to use a trustbadge on my website by aplying the corresponding shortcode: [cusrev_trustbadge type=”VSL” color=”#FFFFFF”] with a Text Block.

    Unfortunately, however the trustbadge is not displayed correctly. Please have a look and let me know your thoughts.

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support Neo WhiteRabbit

    (@longnguyen89)

    Hi,

    Thank you for using CusRev.

    Can you please share your site URL or page URL? I will help you to check the issue.

    Thread Starter kmam

    (@kmammasis)

    Hello,
    thanks a lot for your reply. Please see the URL in the following link. Sorry, I do it this way but I don’t want my website to be indexed in search results via wordpress.org. Please visit the above link and scroll somewhere in the middle of the page, where I have injected the trustbadge by using a text block, where I pasted the shortcode: [cusrev_trustbadge type=”VSL” color=”#FFFFFF”]. No matter where I place it, it looks incorrect. For example, the stars are not aligned correctly and there seems to be thick lines like the encircled one on the right of the trustbadge. Some cannot be seen due to the background color.

    I have also added it at the very bottom of the page the footer. https://ibb.co/njxNSSS

    Thanks a lot and looking forward to solving this one.

    • This reply was modified 3 months, 3 weeks ago by kmam.
    • This reply was modified 3 months, 3 weeks ago by kmam.
    Thread Starter kmam

    (@kmammasis)

    I have managed to make some progress, which you may see in the /kr frontpage. there seemed to be some initial padding applied, causing those extra bit of “lines” appearing due to the padding spaces. So I had to apply the following CSS code:

    /*fix trustbadge size and gaps */
    .cr-badge.badge-vs {
    		border-radius: 50px;
    	  color: #fff;
    }
    .cr-badge-vs-flex .comment-text p,
    .text-page p {
      margin-bottom: -30px; 
    }
    
    div.container.main-wrapper div.inner-page.text-page.margin-disabled div.row.centered div.col-xl-12.col-xs-12.text-page article#post-9125.post-9125.page.type-page.status-publish.hentry div#entry-div.entry-content.clearfix section.vc_section div.vc_row.wpb_row.vc_row-fluid div.wpb_column.vc_column_container.vc_col-sm-4 div.vc_column-inner div.wpb_wrapper div.vc_wp_text.wpb_content_element div.widget.widget_text div.textwidget code {
     padding:0px 0px;
    }
    /*end of fix trustbadge size and gaps */

    Unfortunately, I cannot still get it to appear as desired. Especially, that bit where the number of reviews are displayed, that is currently on a white elliptical background on the right side of the trustbadge. Just not sure how to get this color set to a slightly darker version of the green color appearing on main area – in order for the number of reviews (currently in white color) to come to life. At the moment the reviews are not shown because both the background and the text color is white.

    Hope it helps to clarify the situation.

    Thanks again

    • This reply was modified 3 months, 3 weeks ago by kmam.
    Plugin Support Neo WhiteRabbit

    (@longnguyen89)

    Hi,

    Thanks for your additional information.

    Regarding the issue of the last star displayed under other ones a little bit, I see you are using a page builder to add the shortcode. Please try to deactivate this builder, add the shortcode to a new page then re-check this issue.
    Refer to this solution https://help.cusrev.com/support/solutions/articles/43000611175-troubleshooting-plugins-and-themes

    Thread Starter kmam

    (@kmammasis)

    Hello,

    It has been and still is difficult for me to resolve this. I have invested a lot of time in order to create a fresh local copy of my theme – in order to follow your advice about the deactivation of the plugins and pagebuilder (WP Bakery).

    I can confirm that the issue is not related to the page builder. In fact, by doing so, I found out that what I was seeing before by using the shortcode: [cusrev_trustbadge type=”VSL” color=”#373737″] was incorrect since the store rating was not displayed at all. Now I can see this option exactly above the product rating on this badge.

    Anyhow, part of the issue persists, which means that it is not 100% theme-related, but somehow to the settings of the plugin itself – and/or some other conflict with one of my plugins.

    I was aiming to find a quicker fix, and to be honest with you, I do not have enough time to dedicate for simulating this error on my local environment.

    Thanks very much for your help so far but I will have to abandon this.

    Best wishes,
    K

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.