Support » Plugin: Testimonial Rotator » Using the “average star ranking” shortcode in elementor leads to an error

  • I just tried out the new shortcode using elementor’s “shortcode widget” and strangely after a few tries, elementor refuses to load the page (it can be looked at fine when previewing) with an error about not being able to load the “the-content” function.
    Disabling the testimonial plugin fixes it.

    Hoping this isn’t too much of a hassle to look into, it would be great to get it working somehow, as it isn’t too practical to disable the plugin each time some work has to be done on the corresponding page…

    Thanks in advance
    Best Regards,
    Christian

Viewing 8 replies - 1 through 8 (of 8 total)
  • ChriKn

    (@chrikn)

    Hi Hal,

    Did you have time to look into this bug ? As given in my last comment apparently the fix is quite easy !
    Hoping to hear from you soon and whishing you a nice day

    Best regards,
    Christian

    Plugin Author Hal Gatewood

    (@halgatewood)

    Been out of town for a while. Just submitted version 2.5.2 that should fix this.
    Thanks,
    Hal

    ChriKn

    (@chrikn)

    Hal, you truly are awesome !
    Thanks for the effort 🙂

    ChriKn

    (@chrikn)

    Sadly it still does break Elementor. I am getting this exact error :

    “Sorry, the content area was not found in your page. You must call the_content function in the current template, in order for Elementor to work on this page.”

    The error only appears on pages where a testimonial shortcode is loaded. (for me it would be homepage and “testimonials” page)

    I will dig a bit deeper and try to find a solution.

    Of course, you still are awesome 😉

    Best Regards,
    Christian

    Plugin Author Hal Gatewood

    (@halgatewood)

    Can you try modifying my plugin on the file:
    /wp-content/plugins/testimonial-rotator/testimonial-rotator.php

    Line 685 it says wp_reset_postdata(); can you change that to wp_reset_query();

    Hi Hal,

    I tried it, sadly it didn’t work…

    If I can help you test other things feel free to ask !
    Thanks for your help and dedication

    Hi Hal,
    Hope you are well.
    Sadly this still leads to errors… Did you have time to look into it ?
    I would be glad to help.

    Best Regards
    Christian

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.