Support » Plugin: Same Category Posts » Using ‘cat-all%’ in widget tittle doesn’t work anymore

  • Resolved cricku

    (@cricku)


    The widget title doesn’t show the links.
    I just got only the HTML code printed out.

    Any ideas on how to fix this?

    • This topic was modified 4 years, 3 months ago by cricku.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Daniel Floeter

    (@kometschuh)

    Sorry I haven’t problems with the version 1.0.11.

    Which PHP version do you use?
    What is the name of your used WordPress Theme?

    I set a apply_filter to ‘widget_title’. It’s the widget title. So I think your Theme have a add filter function for this filter? You can find this maybe in the Themes functions.php.

    Thread Starter cricku

    (@cricku)

    Hi Daniel,

    Thanks for your answer. I search in my theme function.php and I don’t have any filter applied to widget_title. I look into the plugin code and replacing this line worked for me:

    echo apply_filters('widget_title',$linkList);

    replace with
    echo $linklist

    Plugin Author Daniel Floeter

    (@kometschuh)

    If no filter is added there can’t be a filer applied.

    That’s why I don’t change anything in the widget code.

    Do you use a free Theme?
    Can you write me the name of your used Theme?

    Thread Starter cricku

    (@cricku)

    Hi Daniel,

    Yes, I use a free theme “bootstrap-ultimate”. The theme it’s no longer maintained from April 2014. Can you give me an example of how I can add a filter in function.php file?

    Plugin Author Daniel Floeter

    (@kometschuh)

    I fixed the issue on GitHub.

    Are you familair with GitHub?
    Because you can download the code there (https://github.com/DanielFloeter/same-category-posts) and copy it to your plugin folder ([your-wp-installation]/wp-content/plugins/same-category-posts) to your wordpress installation or upload the ZIP file with WordPress (Dashboard > Plugins > Installed Plugins > “Add New” button > “Upload Plugin” button >)

    And give me a short feedback? Than I will release this version on wordpress.org.

    Thread Starter cricku

    (@cricku)

    Works like a charm.

    Sorry for late response, didn’t see the notification mail.

    Thank you!

    • This reply was modified 4 years, 3 months ago by cricku.
    Plugin Author Daniel Floeter

    (@kometschuh)

    If you want to say thanks you can rate our free widget here with a 5-stare rating: https://wordpress.org/support/plugin/same-category-posts/reviews/?filter=5

    That would be great.

    Daniel
    😉

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Using ‘cat-all%’ in widget tittle doesn’t work anymore’ is closed to new replies.