WordPress.org

Forums

Scalable Vector Graphics (SVG)
[resolved] Using SVG in Media Uploader Not Working (8 posts)

  1. cbarnett
    Member
    Posted 2 years ago #

    Hi,
    I thought I understood from your changelog that with this plugin as of version 2.0, SVG files should be able to be used as regular images. However I tried uploading an SVG file just as I would a jpeg or other image file, and using the "Insert media" Dialogue to add the svg file to the post, and it merely displays a little icon that looks like a picture ripped in half to symbolize a broken image.

    I created this SVG file in Illustrator.

    I admit I'm new at using SVGs but I thought I understood with this plugin active, it should enable the use of SVG files like any image file.

    This is the code the HTML editor shows after "inserting" the image (which at full size says it is 0 x 0 pixels) into the post:

    <a href="http://lumistaging.designiscasual.com/authasas/authasas-logo-jk/" rel="attachment wp-att-5801"><img class="alignright size-full wp-image-5801" title="Authasas logo" src="http://lumistaging.designiscasual.com/media/Authasas-logo-jk.svg" alt="" /></a>

    http://wordpress.org/extend/plugins/scalable-vector-graphics-svg/

  2. Sterling Hamilton
    Member
    Plugin Author

    Posted 2 years ago #

    That one appears to work for me..

    Can I get more information like browser brand/version etc?
    http://supportdetails.com - could you send me the PDF from here?

  3. cbarnett
    Member
    Posted 2 years ago #

    I sent you the support details form, I think. Let me know if you didn't get it. Thank you.

  4. dmoon79
    Member
    Posted 2 years ago #

    +1
    I'm not able to upload a svg using the media uploaded in WordPress.

  5. anthonyliuhao
    Member
    Posted 2 years ago #

    +1

    I am having the same issue as cbarnett. It looks like the .svg file was uploaded to the server successfully, as I can locate the file when I remote into the server, but WP is denying access to the file. When I copy the File URL to the browser and visit that link, WP throws a 404 Error.

    And ideas would be appreciated!

  6. magicvince
    Member
    Posted 1 year ago #

    Works for me but I think you should tell us:

    Your browser
    Your OS
    Your SVG editor
    Your WP version
    Your Plugin version

  7. MiracleMileGirls
    Member
    Posted 1 year ago #

    This isn't working for me. I'm using wordpres 3.6.1 on safari and this plugin version 2.1.1

  8. christyfm
    Member
    Posted 1 year ago #

    This isn't working for me either. I am trying to put an svg version of my logo in the header. I am able to upload the image to my media library but I can't publish.

    When I try to publish in the header, I get an error, try again message. So I tried just inserting in into a page. In this case, I do not get an error...it just doesn't appear, at all.

    Browser: Chrome
    OS: OS X 10.8.5
    svg editor: Adobe Illustrator (CS6)
    WP version: 3.7.1
    Plugin version: 2.1.1

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Scalable Vector Graphics (SVG)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic