Support » Plugin: AMP » Using Stories

  • Hello,

    I want to allow AMP Stories on my website, but I see that this feature on beta and I need to use the latest version of Gutenberg.

    Here is a screenshot I saw: https://prnt.sc/pg5t71

    But my default content editor is Gutenberg. So I need to install it manually?

    I also see when I click on that link, I moved to “plugin-install.php?tab=beta“.

    Here is my site: https://hazit.co.il/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Pascal Birchler

    (@swissspidy)

    Hi there,

    Great to hear you’re interested in using AMP Stories.

    The AMP Stories editor is built on top of the Gutenberg editor, and leverages some of the latest features that are only available via the Gutenberg plugin, and not in WordPress 5.2. When WordPress 5.3 is released, just using that will likely be enough. But for now you’ll need the plugin.

    When you click on that link, you are indeed redirected to /wp-admin/plugin-install.php?tab=beta, from where you can install and activate the Gutenberg plugin. Is that not working for you?

    I think it works but it seems that stories have issues for RTL languages.

    Also, I’ll happy to know how to show it to users? there is an option to add these stories to the top of the page, like stories on Instagram?

    Also, how it is shown on Google?

    Plugin Author Pascal Birchler

    (@swissspidy)

    Yeah unfortunately there are some small issues with RTL languages, which we hope to fix with the next release in a few weeks. Sorry for the inconvenience!

    As for showing stories to users, you can use the “WordPress Embed” block and the “Latest Stories” block on your site to embed stories in a regular post with a nice preview. That way users can simply click on the preview to read the story.

    In some scenarios Google search will also highlight featured stories in a carousel.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.