Support » Plugin: Responsive Slider » Using shortcode on front page – no images

  • Resolved neon22


    I’m following the instructions and using the shortcode [responsive_slider] on my front page.
    When I view it I see the navigation buttons and the slide titles.
    But I don’t see any images. I’m pointing each slide’s url to my own library as the images are already uploaded. I hope that’s legal ?

    I see the use of <?php echo do_shortcode( ‘[responsive_slider]’ ); ?> if I was putting it into a template but I just want to use the shortcode.
    Seems like its the ‘echo’ part I’m not getting.
    Any clues for using the shortcode in 3.5.1 ?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Just to clarify something that isn’t clear to me.

    Is it that the featured image is what gets shown as a slide (presumably resized internally into some other ‘thumbnail’ format) and the url is where the user will navigate to if the image is clicked on ?

    I’ve tried using the php in a template and i still don’t see an image.

    But I have found something weird going on. If I edit a slider I have already made – when I select featured image it seems to be pointing to a blank image – first item in my library. In fact all the slides are pointing to the same blank image…
    However if I look in Media library on its own – there is no blank image.

    If I try to change the featured image to point to any other image in my library – it appears to succeed but on opening for edit again the featured image is always pointing at this blank empty – non-existant image in my library…

    Ideas ?

    I have also tried uploading fresh images to use instead of pointing to existing library. Still no images visible.
    Not sure where else to look…

    test site is here:
    slider is on homepage

    Plugin Author Griden


    There aren’t any images in the slider markup – that’s what I can tell. If you’ve set a featured images for each slide, then there should be some other reason for them not showing up.

    You can try the standard procedure – disable all plugins and see if that helps. If yes, then enable them one by one to identify the plugin causing this.

    I am likewise having this problem. Happened after the update to 0.1.8. I’m also using the shortcode on the homepage.

    It could be another plugin. I’m just going through them all now and disabling them to see what pops up and will report back.

    I added an echo before do_shortcode and i’m back in business.

    andyjimmy – where?
    I tried:
    echo [responsive_slider] and other variations… Do you mean you edited the php in a template ?

    I originally had:
    <?php do_shortcode( '[responsive_slider]' ); ?>

    And then all of a sudden no images would display, and there wasn’t any markup for the slider when i viewed source. Just as you described.

    But this morning I added in echo like this:
    <?php echo do_shortcode( '[responsive_slider]' ); ?>

    And it worked again. I don’t know what changed, but as long as its working 🙂

    I deactivated all plugins – even the ones to keep my theme working.
    I tried the shortcode and embedding the correct (with echo) version of the php into the template. All to no avail.
    I can clearly see, by comparing to the demo site, that my links do not contain images.
    I get the div class=”slide” and I get the second anchor in the h2 title
    but I am mising teh first anchor with the img tag inside with class=”slide-thumbnail wp-post-image”

    It seems to me its def something to do with my inability to select “Featured image” on the slide page. But in 3.5.1 I have deactivated ALL other plugins. to no avail.

    So sorry – it doesn’t work for me 🙁

    I have been forced to use the vastly inferior “Easing slider” and I note that to get it to work I had to use its ‘disable jquery’ option which turns off its own jquery load to avoid a conflict with an already loaded jquery lib.
    Not sure if that’s any help…

    man this is driving me crazy. Its some collision with the theme. Portfolio-press.
    but can’t work out what the collision is 🙁

    When the theme is not activated – I see an image in the “slide Image” field on the Edit Slide page when I’ve selected a featured image.
    But with the theme activated no image shows. But slides I made while the them was inactive do now work properly.

    So something in the portfolio press theme is inhibiting the selection of images when using the “featured image” on Edit Slide page.

    The solution is to add this to the end of the functions.php file in the portfolio-press theme:

    /* allow other posts to have featured images again */
    add_theme_support( 'post-thumbnails' ) ;

    @andyjimmy Thanks for discovering the info about adding the echo. I was having the same problem after the update. Adding echo worked.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Using shortcode on front page – no images’ is closed to new replies.