Support » Plugin: Smush Image Compression and Optimization » Using plugin but Google Page Speed Test says Images Aren't Optimized?

  • Resolved SLIS


    I’m confused. My google page test scores keeps saying: Optimize the following images to reduce their size by 193.1KiB (20% reduction).

    Shouldn’t using this plugin correct that error? I always smush my images and try to load smaller file sizes of large images when adding to my library. So not sure why I keep getting that error?

    Any advice on this?



Viewing 9 replies - 1 through 9 (of 9 total)
  • Mike


    WPMU DEV Support Staff

    Hi @slis

    Could you be seeing a cached copy? Can you try deleting cache and testing again with Page Speed to see if this changes?

    Also are you sure that the images it’s testing have definitely been smushed? It could be your logo, background image or something similar that’s referring to.

    Hey there.

    We haven’t heard from you in awhile, so I just wanted to check in to make sure all was good.

    This thread was marked resolved, but please, if you still need help then just respond and open it back up. We can then take it from there. πŸ™‚

    Hope you have a fantastic day!

    Well I tried emptying the cache and here’s the speed tests I’m getting via google and gmetrix. I see that the share this plugin is causing some loading issues, but they also list several post images that I did smush with your plugin.

    Any insight would be helpful. A few times I got a ‘backend error’ which is new. And the speed test varies from time to time.

    Also I recently had to disable the minify portion of W3 because the new version was wrecking havoc on my site, just FYI.


    Looking at your first link. When I view the first tab ‘Page Speed’ then click on the row for ‘Optimize images’ which is rated as an A by the way. I see the listing of images. From that listing I see very few image which are from your hosted media library.

    Take the first image: could save 15.9KiB (17% reduction).

    Not the URL is not your website. This is probably because you are running JetPack which copies your images to the WP site like a CDN (Content Delivery Network). These remote images cannot be processed by Only local images on your site.

    Continuing on the images list I see the second image is on your site. could save 8.5KiB (4% reduction).

    So try this. Go to Settings > Media then look for the section. You should see a checkbox to enable debug output. Set the checkbox and save the settings. Then head over to Media > Library and find that image in your listing. Check the last column of the image. what does the information read? DO NOT CLICK the SMUSH.IT in the column. Instead on that row set the checkbox. Then select the option in the dropdown above the media listing. Then the button to the right of the dropdown.

    The bulk of the rest of the images listed in the speed test are for theme or plugin images. Theses does not and will not process.

    Thanks for your reply. Well I just enabled Photon on Jetpack yesterday…which is pretty dumb on my part for not mentioning it! Sorry. Do you recommend I disable it and just use smushit?

    I’ll look into the Media Library settings per your instructions for the other image.

    Thank you!



    WPMU DEV Support Staff

    Photo is a CDN service and doesn’t work with CDN services.

    Does it work if you disable photon? Do they show as optimized then?

    Goodness I apologize for not replying sooner…I thought it was working and forgot to reply. Problem is…it’s still not working :-(.

    Photon is disabled and many of the images it’s mentioning do show as compressed in the smushit including the ‘rain on window glass’ image. But the page speed reports suggest otherwise. So odd.

    Here’s a list of recent speed reports on gmetrix and google.

    One last thing; if I upload an image to a post, does it matter if I smush the image before attaching it? And if I was to publish the post and smush image afterwards would that not still work? At this point that’s all I can think of? I try to be diligent about doing it at the start but sometimes I forget, so wanted to rule that out. And I am currently using W3 minify again in concert with Page cache.

    Thanks so much and apologies for not replying after so long!

    I’m also searching a better and automatic solution for this issue you’re facing. WP does optimize images, but not to the maximum level for each image.

    That’s why Google PageSpeed Tool shows few images that can optimize further. As a manual solution for this issue, you can use GTMetrix or Google PageSpeed Browser addon to get each optimized image one by one.

    This manual method is not good for performance optimization projects, because it takes lot of time for sites that contain lots of images.

    Can developers of WP add the image optimization engine, system used by Google PageSpeed Tool?

    That’d be perfectly appreciated.

    Shyam Chathuranga

    Hi Shyam,

    I hope you are well today and thanks for your feedback.

    The WP plugin is developed to reduce image file sizes and improve performance using the API within WordPress.

    Basically the plugin is developed to implement service provided by Yahoo in WordPress as its name suggests so currently we have no plan to implement any other image optimization service in it, probably we will develop a separate plugin for implementing other image optimization engine.

    Ideally its not a good process to post on a thread 9 months old. The plugin has changed since then and so has WordPress πŸ™‚

    If you have any question regarding this plugin then could you please open a new thread for your new question as per theΒ Forum Welcome, you should post your own topic?

    This might also help other members looking for a similar answer as I’m sure you understand this πŸ™‚


Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Using plugin but Google Page Speed Test says Images Aren't Optimized?’ is closed to new replies.