WordPress.org

Support

Support » Themes and Templates » using php's require

using php's require

  • I feel a bit stupid asking this question however whenever I put this

    require ‘./facebookapi/src/facebook.php’;

    into my header of my theme the header crashes, crashing the entire site.

    I have tried using an absolute path to and it also breaks the page.

    What am i doing wrong?

Viewing 1 replies (of 1 total)
  • Are you following some tutorial or plugin details that is asking you to add this? Just trying to figure out what you are trying to achieve and get full picture if possible.

    Also, can you confirm you are adding like this:

    <?php require('./facebookapi/src/facebook.php'); ?>

    http://php.net/manual/en/function.require.php

    Depending on location you could try $_SERVER["DOCUMENT_ROOT"] to get the location.

Viewing 1 replies (of 1 total)
  • The topic ‘using php's require’ is closed to new replies.