Support » Plugin: Edit Author Slug » Using OneLogin, Plugin appending “-2” to username every login

  • Resolved ryanfbaker


    Hey there,

    This plugin has been very helpful, but we just switched over to using OneLogin to manage our wordpress login access at our company, and we are seeing some strange behavior in the plugin where it appends -2 to the end of a person’s username every time they authenticate.

    1. I set my login name to be ryan-baker (first-last)
    2. I log out of wordpress.
    3. I log in through our OneLogin connector.
    4. Edit Author Slug has changed my login name to be “ryan-baker-2”

    Every subsequent login, it repeats the append, so eventually it’s like “ryan-baker-2-2-2-2-2-2-2”

    Any tips?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Brandon Allen


    Sorry for the delay in response.

    I’ve have written multiple tests, and I can’t make this happen. If you’re still using the plugin, I’d be interested to hear what you’re Edit Author Slug settings are. Specifically, do you have automatic author slug creation turned on?

    The “-2” suffix is not something my plugin adds. That’s done by WP itself.

    Also, you say that your login name is changed. My plugin doesn’t change your login name, but I suspect you are referring to the author slug (in the context of code/database this is technically the user_nicename).

    Thread Starter ryanfbaker


    Brandon – I ended up just checking the “Automatically update author slug…” checkbox – this fixed the problem. Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Using OneLogin, Plugin appending “-2” to username every login’ is closed to new replies.