Support » Fixing WordPress » using nvda/firefox combo, keyboard navigation broken in 3.8

  • Hi, Team:

    Well, I’ve finally had some time to look at accessibility issues in 3.8. The sites in question are using Weaver II–1 uses the free version, the other uses Pro. I haven’t tested w/default themes, but I will. When attempting to activate a link, e.g., the ‘Pages’ link in the admin dashboard using the latest version of NVDA, I’m instead put back on my desktop. I’m running the latest version of Firefox, & I note this does not happen w/IE. Nor does it happen w/Jaws. So–something changed/broke w/that particular combination between 3.71 & 3.8. Wah!–it’s my favorite. I’m going to raise this issue w/NVDA developers as well, but, when it comes to testing web accessibility, NVDA is likely the gold standard, simply because it tends to bring out problems fairly dramatically. So, it might be something that we as members of the accessibility team wish to examine in greater detail.

    Let me know how I might assist, ok?

Viewing 10 replies - 1 through 10 (of 10 total)
  • FWIW, I do not believe this is (necessarily) related to themes as I was able to recreate the issue with NVDA/Firefox and I am not using Weaver on the test site.

    I am, however, not using any of the default themes.

    It does the same thing using the 2014 theme, so I believe we can safely conclude at this juncture that it’s not theme related. Basically, I cannot activate any links in the admin dashboard whatever using NVDA & Firefox. Even when I press insert f7, highlight the link & choose the ‘activate’ option, there’s a quick second where my screen flashes back to the desktop, then I’m returned to the site, but the link is not in fact activated.

    This is pretty trippin! Not good!


    I can’t reproduce this with the latest NVDA snapshot+Firefox. Could you please give it a try? You can download snapshots here:

    You don’t have to actually install an NVDA snapshot, just run the downloaded file and it will start as a portable version.


    Bramd, I can try this–& I will–but this is pretty bleeding edge for a lot of blind folks. Many just want to have their blog & not be concerned w/snapshot versions, preferring instead to update only when a stable release is issued.

    Here’s what else I discovered, in case it’s helpful. Installing OZH Admin Dropdown menu solves the problem. My concern is that it hasn’t been updated for awhile. It does appear to work w/3.8, however. So whatever it’s doing to the menus, it’s solving accessibility issues as well. Actually, I found this to be the case in wp 3.31 as well when admin accessibility was broken pretty badly. I hadn’t been recommending lately that folks install OZH Admin Dropdown, because the admin dashboard had been working quite well for awhile, but I’m going to have to reinstate that recommendation, I guess, although I do it w/great hesitancy, because, as stated, it hasn’t been updated in a bit, & I don’t know if it’s still being actively developed/maintained. That’s always a serious concern.

    @abletec: Sure, this is bleeding edge and not something I would recommend. However, if we can verify that it’s fixed using the snapshot builds, we can be quite sure it will work again in the next NVDA release.

    If we end up concluding this is a bug in WordPress and not in NVDA, we should be able to fix it and get it in a 3.8.x release because it would be a regression from the previous version. Therefore, I would be hesitant to advise the use of plugins right now. That being said, I totally understand that people affected by this *really* need an immediate solution to use the admin effectively again.

    @bramd, I confirm that this does indeed work w/the latest snapshot of NVDA.

    As I said, I hesitate to recommend plugins also. On the other hand, I have clients who make their living via their websites, & they’re locked out–& beyond pi$$3d. My obligation is to them, & I’ve gotta help them yesterday. At this point I don’t see I have a lot of choices, but I’m willing to listen if you or anyone else has any suggestions.

    So I guess my question is, how does the accessibility team go about coordinating our efforts so that we can test this stuff &, at the very least, aren’t blindsided when these changes occur, if you’ll all pardon my expression. I’m not criticizing any1 here–it’s just that as a relative newbie to the team, I don’t know how it all works, what yall’s protocols are, etc. So I’m asking questions & trying to get oriented.

    I want to help–I just don’t quite know how to get started. & I don’t want to appear like I’m whining or asking for handholding, either. But if some1 could give me a nudge or kick in the tuschy in the right direction, that’s likely all that’s necessary. Private contact is also welcome.

    Thanks. I was actually 1 of the major participants in that thread. I couldn’t reproduce her problem, either w/Jaws & firefox or using IE w/any screenreader. But there’s sure a problem w/NVDA & Firefox. The thread, along w/problems some of my clients were having, was what caused me, in fact, to examine this in greater depth.

    @abletec: I’m not really sure about the protocols/procedures either. However, the first step is to check if we have indeed a bug in WordPress. I think we should verify this with other screenreaders and if it works everywhere except the NVDA stable release assume it’s an NVDA bug that has been solved in the meantime. If we can reproduce it with other screenreader and/or browser combinations, we might have a WordPress bug. Then we should figure out what exactly causes this and put it in a ticket so someone can work on a patch to fix this.

    This is also what happened in the above linked thread, for that issue is now a patch that seems to be ready for inclusion in WordPress 3.8.1.

    I couldn’t reproduce her problem, either w/Jaws & firefox or using IE w/any screenreader. But there’s sure a problem w/NVDA & Firefox. The thread, along w/problems some of my clients were having, was what caused me, in fact, to examine this in greater depth.

    I am almost certain the OP in that other thread’s issue was because of zoom. When she reset her browser (and tweaked some other unknown settings in her screen reader) it worked as intended.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘using nvda/firefox combo, keyboard navigation broken in 3.8’ is closed to new replies.