Support » Requests and Feedback » Using Mysql 4.1.10… Not working..

  • I’m currently using a configuration like this:
    Apache 2.0.53, PHP 5.0.3, MySQL 4.1.10, WordPress 1.5

    Don’t know if this post should be here on in some other category, but I’ll try here first.
    On to the actual question/problem;
    I can’t make the installation work..
    Since I’ve got mysql 4.1.10 that doesn’t want anything to do with the old mysql_select etc. statement, I tried to exchange them for the newer mysqli ones instead. Mucked about a little with the code, and I got the installation scripts to show up.
    I actually seem to get through the entire install.php sequence, without any errors, but nothing is actually written to the database. no tables are created at all. Tried to run the thing through a debugger, but that one crashes when trying to use the mysqli functions.. I’m no expert at PHP whatsoever, and I can’t find where the possible error might be.
    Is there anyone else out there who has tried to make wordpress work with php5 and the newer versions of mysql? Someone who actually made it work? Or is there anyone who knows when wordpress will support the newer mysql interface?

Viewing 2 replies - 1 through 2 (of 2 total)
  • With the exception that my server is Apache 2.0.52 still, I have the identical setup and no problems whatsoever. PHP5 includes the newer authentication schemes for MySQL 4.1 (where PHP4 breaks with anything higher than MySQL 4.0 unless you either compile mysqli into it or change some 4.1 settings – or don’t put a password on your database account).

    As far as I know, you shouldn’t have had to change anything at all if your setup was previously working.

    As for the MySQL interface, nothing that WP uses has changed (to my knowledge). The main change is the MySQL client authentication library, and if you’re using PHP5, it should work just fine.

    I’ve been scratching my head over this all night.. Never even occured to me that something was wrong with my PHP settings =)
    After I read your reply saying that it worked fine for you with that config, I started going through every setting and config file again…
    Guess what I found? I only had php_mysqli.dll loaded in php.ini, not php_mysql.dll. Just added a line in the ini file and everything works like a charm right out of the box!
    Thanks for your swift reply man, you’ve saved my day!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Using Mysql 4.1.10… Not working..’ is closed to new replies.