Support » Localhost Installs » using MAMP to run word press on my mac.

using MAMP to run word press on my mac.

  • Hi good wordpress people,

    I am trying to install word press o nmy mac so as to work offline on my website, But I can’t get past thefamous5 minute install, I get the following error.

    We were able to connect to the database server (which means your username and password is okay) but not able to select the wordpress database.

    Are you sure it exists?
    Does the user have permission to use the wordpress database?
    On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?

    the database exits, user has all required permissions, suggested username change does not work. Any ideas?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Drew Jaynes


    Docs Czar

    Moved to Localhost Installs

    Have you tried using the default “root” user with the password “root”? Have you made sure that MySQL and Apache are both running?

    Hi Drew, username and password are okay. Root as user and root as password are being used. Apache and MySQL are running.

    Drew Jaynes


    Docs Czar

    That’s strange. Is it possible that you have other MySQL processes running from outside of what I’m assuming is MAMP? You can check this in Activity Monitor. If there are more than on MySQL processes running, try killing all of them, restarting the services and trying again.

    Hi Drew, seems I have stepped backwards. I did have filezilla opened to my main site. So I closed all that to try again. Now i am getting a MySQ error….#08S01Got packets out of order


    did you solve your problem? actually i just had exactly same problem and just solved by change name of database on MAMP.

    My mistake was to create new DB name on MAMP different than wp-config.php file. Meaning, if you had this one your txt ( wp-config.php file )file, then you should have the SAME DB name as ‘wordpress’ on MAMP phpmyadmin page when you create new DB.
    Hope it helps. If not, let me know. :))

    define(‘DB_NAME’, ‘wordpress‘); //database for WordPress
    define(‘DB_USER’, ‘root’); //database username
    define(‘DB_PASSWORD’, ‘root’); //database password
    define(‘DB_HOST’, ‘localhost:8889’); //hostname

    Thank jjaschang,

    I did change the database name in the config file to match the database. same problem. I will recheck everything and try again being mindful of your database naming advice.

    I do not even get that far now….

    currently when i go to…

    i get the following error:

    5.5.29����JY`WrYG9�ÿ÷�€����������&RKb,S;n:sX=�mysql_native_password�!��ÿ„#08S01Got packets out of order

    This is getting very frustrating. 🙁

    So MAMP isn’t working now?
    If not reinstall MAMP

    The wordpress installation is in a subdirectory of your htdocs folder – right? – the WordPress files aren’t just loose in htdocs.
    If not place them in a subdirectory.

    And when you started WordPress for the first time you put the name of this subdirectory for WordPress to use as a root folder?
    If not create a fresh new database and reload WordPress – enter the correct root folder name for this WordPress install.

    Still problems?
    Try giving your database name only a-z or 0-9 characters or hyphens – no unusual characters. Same for database username and password.

    Otherwise this could be an issue with MAMP.

    Hey Polo Joe, I got the same output when I copied all of the files from the original zip file into another folder. If you bring up a terminal window and go to the directory where you moved them to, then run the following command:
    file *
    It should give you nothing but text and directory entries. If they say data, try expanding the zip file where you want it, not elsewhere.
    Your output should be something like:
    index.php: PHP script text
    license.txt: ASCII English text, with CRLF line terminators
    readme.html: HTML document text
    wp-activate.php: HTML document text
    wp-admin: directory

    This is what it looks like when I copied them:
    index.php: data
    license.txt: data
    readme.html: data
    wp-activate.php: data

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘using MAMP to run word press on my mac.’ is closed to new replies.