WordPress.org

Forums

Using MAMP to copy site to Localhost and blank screen after setting up the site (3 posts)

  1. Tadasuk
    Member
    Posted 1 year ago #

    Hi,

    I am trying to copy my site to localhost using MAMP. I set up everything and when i go to localhost:80 I see the thumbnail icon, but the page is blank.

    I get this error in php log:
    [05-Mar-2014 13:16:21 Europe/London] PHP Warning: POST Content-Length of 70849755 bytes exceeds the limit of 33554432 bytes in Unknown on line 0
    [05-Mar-2014 13:51:32 Europe/London] PHP Parse error: syntax error, unexpected '');' (T_CONSTANT_ENCAPSED_STRING) in /Users/MacbookPro/Documents/wp/wp-config.php on line 18

    My wpconfig.php looks like this:
    <?php
    /** Enable W3 Total Cache */
    define('WP_CACHE', true); // Added by W3 Total Cache

    define('COOKIE_DOMAIN', 'www.geeknaut.com');

    // ** MySQL settings ** //
    define('DB_NAME', 'geeknaut_gn');
    define('DB_USER', ‘root');
    define('DB_PASSWORD', ‘root’);
    define('DB_HOST', 'localhost');
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    // Change each KEY to a different unique phrase. You won't have to remember the phrases later,
    // so make them long and complicated. You can visit http://api.wordpress.org/secret-key/1.1/
    // to get keys generated for you, or just make something up. Each key should have a different phrase.
    define('AUTH_KEY', '`+4UmTtzhy5#[BO, QP*d9J,]rY<J4PFEMOl&HS,Gkr&-heN4@$<;*P^9+ ?YWu_');
    define('SECURE_AUTH_KEY', 'E<T~l[5o(I_& w~<u_mJkyq9.7zEX|@*~(:/`MjQ=W.w4(M3[yaU?#=Aof&RM]m8');
    define('LOGGED_IN_KEY', '@,3@*)/hI-|Z8Ju$)|kCA5@-G<3O5+nY7l+/e]+r$Zfo~Ul:OQFJ0AA{}IbNg5;O');
    define('NONCE_KEY', 'T9-s5z7^q+_w7V99,9EaPEAvC1/^F2qC,gK3&i.. _JQ$;8r3PbfkuPn-=`=?QNA');
    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'gn_'; // Only numbers, letters, and underscores please!
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    /* That's all, stop editing! Happy blogging. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');
    require_once(ABSPATH . 'wp-settings.php');
    ?>

    Don't know what other information I can provide. Let me know if you need anything else?

    Please help with this?

  2. keesiemeijer
    moderator
    Posted 1 year ago #

    You have curly quotes here:

    define('DB_USER', ‘root');
    define('DB_PASSWORD', ‘root’);

    Try and change it to this:

    define('DB_USER', 'root');
    define('DB_PASSWORD', 'root');
  3. jtrag
    Member
    Posted 1 year ago #

    Good eye keesiemeijer ;)

Topic Closed

This topic has been closed to new replies.

About this Topic