Support » Plugin: Wordfence Security - Firewall & Malware Scan » Using Falcon blog is cached but cached pages aren't served

  • Resolved luigitec

    (@luigitec)


    Hello awesome Wordfence team,

    I’m running a blog on a subfolder http://domain.com/wordpress-blog being the domain.com a different type of CMS.

    I have the latest WordPress and Wordfence versions installed, I wanted to try your Falcon caching system, I enabled the html debug message to the footer but I never see it in the source code, I do see that it generates a cache file, but just one:

    root@host:/domain.com/wordpress/wp-content/wfcache/www.domain.com_blog# ll
    -rw-r--r-- 1 user group 84042 Sep  2 10:31 ~~~~_wfcache.html
    -rw-r--r-- 1 user group 13371 Sep  2 10:31 ~~~~_wfcache.html_gzip

    Nothing else, the .htaccesfile was correctly generated on the wordpress-blog directory.

    Am I missing something?

    Kind regards,
    -Luis Franco

    https://wordpress.org/plugins/wordfence/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author WFMattR

    (@wfmattr)

    Thank you for the report — Wordfence’s Falcon cache does not show the cached files if you are logged in, or if you have logged into the site in the same browser, to prevent caching pages that shouldn’t be cache. (When you log out, exit the browser altogether, then visit the site again, you normally should see cached pages.)

    Do you have a second browser you can use to visit the site, that has not been logged in? Say, if you are using Chrome normally, try visiting the page in Firefox, and see if the debug comment appears?

    We do have one open issue with subdirectory installations, but I believe it only happens if the WP core files are not in the same folder as the root of the WordPress site. (e.g., when wordpress works when you visit “site.com” while only the core files are in site.com/wordpress)

    Thread Starter luigitec

    (@luigitec)

    Hello WFMattR,

    I appreciate your answer, I’m aware about not caching stuff while being logged in, I ran a script that re-creates the cache after flushing the cache, worked on WP SuperCache, and I as well checked different pages using different browsers with no luck.

    I did disabled the old Super Cache plugin, removed its generated content from the .htaccess file and after that I proceeded to activate Falcon Engine, double checked Falcon engine’s content was added to the .htaccess file but still nothing is being cached. I’ll do some digging to see if I find the issue, I’ll keep you posted.

    Thanks!

    Plugin Author WFMattR

    (@wfmattr)

    Ok, thanks for confirming.

    One item to check is whether you have any other plugins that affect caching — Wordfence does look for certain constants that other plugins might use to tell caches not to save. If you use the Network tab in the developer tools in Chrome or Firefox (and maybe others), you can see if the response contains an “Expires” header in the past — that is a good sign that another plugin is trying to prevent caching.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Using Falcon blog is cached but cached pages aren't served’ is closed to new replies.