WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Using custom permalinks makes previous page go to 404

[Resolved] Using custom permalinks makes previous page go to 404

  • dwejikalbi
    Member

    @dwejikalbi

    I have been trying to fix this for days.

    I always used the custom “post-name” permalink structure and everything was fine. Suddenly when I tried to click “previous page” – it directs my site to /page/2/ but it goes to a 404 page.

    When I change the permalink structure to “default” it corrects this problem but I want to be able to use the custom permalinks because everything is already pointing to them.

    I saw some people had luck when they changed the number of posts per page, but it does not make a difference for me. I have disabled all my plugins. I have tried deleting my .htaccess file, changing the permalink settings, and letting wordpress re-create the .htaccess file. I’ve tried a variety of fixes (adding/removing code from the .htaccess) from other wordpress forums. Nothing has worked for me.

    My site is http://www.sketchbookcloset.com

    My .htaccess file looks like this

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    Options +FollowSymlinks
    RewriteEngine on
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Please, I am desperate for a solution.

    Thanks so much.

Viewing 2 replies - 1 through 2 (of 2 total)
  • dwejikalbi
    Member

    @dwejikalbi

    I corrected the problem by adding this code to my .htaccess file.

    Hope this helps someone else!

    # BEGIN WordPress
    
    <IfModule mod_rewrite.c>
    ErrorDocument 404 /index.php?error=404
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    robertallen
    Member

    @robertallen

    I did that to my .htaccess and I’m still getting 404. Anyone have any ideas on how to fix this? Something wrong with the plugin now?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Using custom permalinks makes previous page go to 404’ is closed to new replies.