Support » Networking WordPress » Using a subdomain of a mapped domain

  • I’ve got a mapped domain on a multi-site install that is working fine. I’m trying, however, to use a subdomain of that mapped domain for another application (a listserv). In WPMU 2.9 I was able to do this. I was using the mapped domain plugin and I just added the domain on to my host and then set up a subdomain. When I installed the application in the corresponding directory, it worked.

    However, since upgrading to 3.0, I can’t get this to work. The main mapped domain is working fine, but when I try to access the installed application at the subdomain I get the following message:

    “No site defined on this host. If you are the owner of this site, please check Debugging a WordPress Network for help.”

    Any ideas how to fix this?

    Thanks!!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Move the record for the subdomain up higher in the apache config file.

    Yes, I know, that’s technical. 🙂

    Basically, the subdomain request is going to the network install before it bothers looking elsewhere on the server.

    your webhost may be able to help fix that.

    @andrea_r,

    Once again you rule, and so you know, we submitted the request to our server admin like this:

    Could you please modify apache configuration on umwblogs.org
    <http://umwblogs.org&gt; so that the domain share.teachumw.org
    <http://share.teachumw.org&gt; has a virtual host declaration that points
    to this folder /home/umwblogs/public_html/share

    Sometimes sharing the terminology of how to ask can be just as helpful as understanding something, which i don’t claim to 🙂

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    No, YOU RULE! *high fives*

    😀

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Using a subdomain of a mapped domain’ is closed to new replies.