Support » Plugin: EWWW Image Optimizer » Using a lot of CPU resources after the last update

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author nosilver4u

    (@nosilver4u)

    Can you be a little more detailed? It uses a lot of CPU when…? When does it use more CPU? If it’s doing it all the time, then EWWW isn’t the root cause, just a symptom. Otherwise, I recommend you read the changelog.

    I can confirm that the new update will use your
    CPU Time Usage

    I too deactivated the plugin it went to normal.
    And from siteground support told me it was ewww-image-optimizer

    my firewall log file shows repeated request listed below

    07/Jul/16 09:12:03 #3394551 high 510 185.123.97.177 POST /wp-admin/admin-ajax.php – DOCUMENT_ROOT variable in HTTP request – [POST:ewwwio_path = /home/gamerswo/public_html/wp-content/uploads/2016/07/ArmA-2-Cheats-PC@2x.jpg]
    07/Jul/16 09:17:27 #5573183 high 510 185.123.97.177 POST /wp-admin/admin-ajax.php – DOCUMENT_ROOT variable in HTTP request – [POST:ewwwio_path = /home/gamerswo/public_html/wp-content/uploads/2016/07/ArmA-2-Cheats-PC.jpg]
    07/Jul/16 09:17:27 #5740852 high 510 185.123.97.177 POST /wp-admin/admin-ajax.php – DOCUMENT_ROOT variable in HTTP request – [POST:ewwwio_path = /home/gamerswo/public_html/wp-content/uploads/2016/07/ArmA-2-Cheats-PC@2x.jpg]
    07/Jul/16 09:22:14 #6682450 high 510 185.123.97.177 POST /wp-admin/admin-ajax.php – DOCUMENT_ROOT variable in HTTP request – [POST:ewwwio_path = /home/gamerswo/public_html/wp-content/uploads/2016/07/ArmA-2-Cheats-PC.jpg]
    07/Jul/16 09:22:14 #1949621 high 510 185.123.97.177 POST /wp-admin/admin-ajax.php – DOCUMENT_ROOT variable in HTTP request – [POST:ewwwio_path = /home/gamerswo/public_html/wp-content/uploads/2016/07/ArmA-2-Cheats-PC@2x.jpg]
    07/Jul/16 09:29:45 #5699797 high 510 185.123.97.177 POST /wp-admin/admin-ajax.php – DOCUMENT_ROOT variable in HTTP request – [POST:ewwwio_path = /home/gamerswo/public_html/wp-content/uploads/2016/07/ArmA-2-Cheats-PC.jpg]
    07/Jul/16 09:29:45 #1981381 high 510 185.123.97.177 POST /wp-admin/admin-ajax.php – DOCUMENT_ROOT variable in HTTP request – [POST:ewwwio_path = /home/gamerswo/public_html/wp-content/uploads/2016/07/ArmA-2-Cheats-PC@2x.jpg]
    07/Jul/16 09:32:27 #2542517 high 510 185.123.97.177 POST /wp-admin/admin-ajax.php – DOCUMENT_ROOT variable in HTTP request – [POST:ewwwio_path = /home/gamerswo/public_html/wp-content/uploads/2016/07/ArmA-2-Cheats-PC.jpg]
    07/Jul/16 09:32:27 #3080736 high 510 185.123.97.177 POST /wp-admin/admin-ajax.php – DOCUMENT_ROOT variable in HTTP request – [POST:ewwwio_path = /home/gamerswo/public_html/wp-content/uploads/2016/07/ArmA-2-Cheats-PC@2x.jpg]
    07/Jul/16 09:32:51 #7282768 info – 46.208.211.91 POST /wp-login.php – Logged in user – [sparks199 (administrator)]

    Plugin Author nosilver4u

    (@nosilver4u)

    The next version will not have root paths in the POST requests, and will play a little nicer with the database.

    The big difference in 2.9 (for everyone that didn’t read the changelog) is that optimization is run in parallel for each image upload. So if you have a dozen resizes, it’s going to run 13 optimizations in parallel, instead of 13 in a row (one right after the other). The CPU usage is roughly the same, except the db query issue I mentioned, just condensed, instead of spread out like before.
    For that exact reason, there is a new advanced setting to disable this behavior.

    Plugin Author nosilver4u

    (@nosilver4u)

    let me know if one of the following does not fix your problems:
    1. updating to 2.9.1
    2. disabling parallel optimization

    I don’t think parallel optimization is ready for prime time. The new version basically kills uploads on my LOCAL install that has tons of resources. With it on, uploads stall out even for really, really small images (less than 100KB). Turning parallel optimization off fixes it but it is on by default.

    I can’t see parallel optimization working even on a VPS or dedicated server with way less resources than my laptop.

    Plugin Author nosilver4u

    (@nosilver4u)

    @joshuaiz, how many resizes is your site processing (check the advanced tab to see the whole list)?

    Right now it’s 6…but it was doing 6 before on many, many sites without issue before 2.9.1 (and parallel optimization).

    Plugin Author nosilver4u

    (@nosilver4u)

    Then I think you have something else going on with your site. I just ran a test on a regular shared hosting account, and it ran just fine with 5 resizes per image. I even hit it with 20 images in a row, and the site didn’t miss a beat.

    Well I have WP Retina 2x running as well and that creates all of the other sizes. All I know is that with both of those plugins and parallel optimization running on MAMP Pro, uploads stall out at some point in the chain.

    With parallel optimization turned off, uploads go through as normal.

    Plugin Author nosilver4u

    (@nosilver4u)

    Could you contact me here: https://ewww.io/contact-us/

    Plugin Author nosilver4u

    (@nosilver4u)

    I got an update notification with ewww version 2.8.5 -> 2.9.3, about 2 hours ago i done the upgrade, then in about 30 minutes a dozen of async optimization requests were made from wordpress to itself, and all were lockin up somehow, until oom-killer or me killed apache. It seemed to me, that the update released some background process which would eventually go trough the whole image library, but without proper warning, i only saw my website going down. If the process is part of the upgrade i suggest a warning, or any information about possible backgroud processing that may cause higher load that expected.

    Currently reverted plugin back to 2.8.5

    Plugin Author nosilver4u

    (@nosilver4u)

    @gna, post your own topic

    @nosilver4u my post is indeed not close related here, but at least it relates to the following two topics:

    Is it worth opening as new topic only for me?

    Plugin Author nosilver4u

    (@nosilver4u)

    From what you’ve said, your issue is different from the others, and forum etiquette states that you should always start your own thread, and let those offering support point you to a similar thread if they are related.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Using a lot of CPU resources after the last update’ is closed to new replies.