WordPress.org

Support

Support » Plugins and Hacks » Theme Switcher Reloaded » uses deprecated functions

uses deprecated functions

  • Looks like a great plugin but uses several deprecated functions:

    line 25 load_plugin_textdomain

    line 247 register_sidebar_widget

    line 251 register_widget_control

    Also if you simply go through and update the function names, you get the error:

    wp_register_sidebar_widget missing argument 3

    It’s possible to correct these issues oneself, but the plugin in its present state (version 1.0) is not compatible with WP 3.7.1 out of the box.

    http://wordpress.org/plugins/theme-switcher-reloaded/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author undoIT

    @undoit

    This is fixed in version 1.1. Please let me know if you find any other errros.

    hello,
    me too, I have deprecated functions notices:
    in widgets.php: Notice: Undefined index: themeswitcher-submit in …wp-content/plugins/theme-switcher-reloaded/theme-switcher-reloaded.php on line 135

    on front, in widget: Notice: get_settings is deprecated since version 2.1! Use get_option() instead. in …wp-includes/functions.php on line 3201

    switching theme, white screen with: Notice: get_settings is deprecated since version 2.1! Use get_option() instead. in /Users/hubertsouchaud/Sites/dev/cms/wp-includes/functions.php on line 3201

    Warning: Cannot modify header information – headers already sent by (output started at …wp-includes/functions.php:3201) in …wp-includes/pluggable.php on line 117

    http://wordpress.org/plugins/theme-switcher-reloaded/

    wp 4.0

    Plugin Author undoIT

    @undoit

    Thanks for the report dmsr. Very busy right now, but I will look into this sometime soon.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘uses deprecated functions’ is closed to new replies.
Skip to toolbar