Support » Plugin: UsersWP - User Profile & Registration » UserWP registration & login has problems with 2FA

  • Resolved entreevous

    (@entreevous)


    Found another bug. If I set up 2FA (2 Factor Identification) and check all the boxes in UserWP to replace the default WP Register & Login screens I will get an endless loop of Login screens.

    Scenario:
    1) I register a brand new user using the Register function of UserWP
    2) I receive the e-mail note with the confirmation link
    3) I click on that link and confirm the userid.
    4) I try to login to the website using the UserWP Login function, I press enter and it says the userid does not exist and sends me back to the Login screen.

    I check on the backend and the user does exist.

    (Repeat cycle a few times)

    I disable all the checkboxes in UserWP to replace the default Register and Login pages. I login using the WP Login page and BAM! I get the default “Setup Two-Factor” screen.

    Methinks that UserWP might not be error trapping again and taking into account that 2FA might be enabled.

    CONFIRMED: I turn 2FA off in WP and UsersWP login works for new users.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Patrik

    (@wpdev10)

    Hi,

    Can you please let us know which plugin you are using for 2FA? Our plugin might not be compatible with that but we will try to make it compatible or create our own 2FA.

    Regards,
    Patrik

    Comclusive

    (@comclusive)

    I have the same issue when using UsersWP lightbox login popup with WP 2FA plugin

    • This reply was modified 3 months ago by Comclusive.
    Plugin Author Patrik

    (@wpdev10)

    Hi,

    We will look into compatibility with WP 2FA soon. Thanks for your inputs.

    Regards,
    Patrik

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.