Support » Plugin: Easy Forms for Mailchimp » Users not added to list during Registration

  • Resolved JustinF

    (@jhf12)


    Hi, what would be the most common reasons why users never get added to a connected MailChimp list using the Registration integration? I have tested across multiple test sites but no luck. Only thing I can think of is that these sites don’t (yet) have SSL.

    EDIT: it’s nothing to do with an IP block, I can confirm.

    • This topic was modified 5 months ago by  JustinF.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor yikesitskevin

    (@yikesitskevin)

    Hi @jhf12,

    The most likely reason is that all of our integration optin checkboxes are double opt-ins and you’re using test email addresses so you can’t confirm your subscription. (i.e. the email addresses you’re using are being sent a double opt-in email but you’re not confirming it).

    Another likely reason is that you have some required fields in your Mailchimp list that we’re not sending during the registration process. We’re only sending the email address when attempting to subscribe users. If your list has another field (e.g. name) that is required then the subscription will fail.

    Let me know if either of those two sound likely.

    Cheers,
    Kevin.

    Hi Kevin-

    Thanks for your prompt reply. So we actually have another plugin (paid) that we use to send to this same list. It works without a hitch (single opt-in). It sounds like this could potentially be the reason.

    Is it possible to make it single opt-in?

    Plugin Contributor yikesitskevin

    (@yikesitskevin)

    You’ll need to use a filter if you want the integration checkbox to be single opt-in. This is the filter code:

    add_filter( 'yikes-mailchimp-checkbox-integration-body', 'set_integrations_to_single_optin', 10, 4 );
    function set_integrations_to_single_optin( $request_body, $integration_type, $list_id, $additional_vars ) {
    	$request_body['status_if_new'] = 'subscribed';
    	$request_body['status']        = 'subscribed';
    
    	return $request_body;
    }

    That worked. Thank you 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.