WordPress.org

Forums

[resolved] Users email says "There is a pending change of your e-mail to admin@mysite.com (15 posts)

  1. 12sp
    Member
    Posted 4 years ago #

    I've noticed this for a while and decided I probably should ask about it.

    When I look at a users profile via the admin board under their email required that has there email in it there is a yellow box that says, "There is a pending change of your e-mail to admin@mysite.com. Cancel"

    I have a non-networked blog and it does not do this.

    The email is the sites main email address. When I click cancel takes me to my profile. When I go back to see if it was cancelled it shows the same message.

  2. Did you change the email address for the admin account?

  3. 12sp
    Member
    Posted 4 years ago #

    No. At least I don't remember doing so. Just the one that I created when I opened the blog.

    The admin@mysite.com is really my admin account email address.

    But even if i did why would it want to change other users email address to the admins email.

    Am I missing something?

  4. Have you tried turning off plugins? I can't reproduce that (and really you should only see that sort of message if it has to do with your ID)

  5. 12sp
    Member
    Posted 4 years ago #

    I deactivated my networked plugins one by one and none of those seemed to effect it. Is there a way to deactivate blog-activated plugins without going to each blog?

  6. Alas no :/ Is this happening on all the sites?

  7. 12sp
    Member
    Posted 4 years ago #

    I just checked and it does not. Only on the network and my main site. The sub-blogs are fine.

    I also checked that is only happens when I'm logged in under the main super admin account.

    I deactivated all the plugins on the main site but the message stayed.

  8. 12sp
    Member
    Posted 4 years ago #

    I changed my super admin email address to see if that would have an affect. It didn't.

    Then I changed the network email address. No change.

    Then I changed the main blogs email address. It sent an email to confirm the new email address, I clicked it, but I'm getting this message below the general settings.
    This address is used for admin purposes. If you change this we will send you an e-mail at your new address to confirm it. The new address will not become active until confirmed.

    So, it looks like it doesn't think I've confirmed it.

    It's possible it said that before and I just overlooked it. How do you think I can get that confirmed?

    I should point out I have no problems logging in.

    (zetaportal.com)

  9. You mean it looks like this: http://cl.ly/2v2w3g2k2N001f0p3Y2O

    That's how it's supposed to look :) It always warns you.

    Can you screenshot this mysterious yellow box?

  10. 12sp
    Member
    Posted 4 years ago #

    Oh yes. Okay, didn't realize that.

    Here is the image.
    I'm logged in as superadmin and this is a shot of a random user.

    http://zetaportal.com/blog/2012/06/20/my-message/message-2/

  11. Okay! I can (partly) reproduce that by changing the email on my main site. And when I hit cancel, it goes away.

    However it only ever shows up on that main site's general settings.

    Deactivate all the plugins on your main site.

  12. 12sp
    Member
    Posted 4 years ago #

    I deactivated everything. Main site and networked stuff and it went away. I'll reactivate them one by one and see what happens.

    Reactivated and it is gone. What I missed doing is deactivating both network plugins and site plugins. I did one and then the other.

    Thanks!

  13. JonnoPrice
    Member
    Posted 4 years ago #

    hi there, I think I have a similar issue but it is not a User as such. Rather I'm trying to change the email address in the General Settings.

    Currently it is my web developer's email and I would like the main admin email (for site backups etc) to be set to my email.

    I change this to admin@mysite.com (which is an email address properly set up and working) and I get the "There is a pending change of the admin e-mail to admin@mysite.com. Cancel" message..,

    The problem is I never receive the change of email notification.

    Question - does the notification email go to the original email address or to the new email address which I'm inserting?

    thanks in advance

  14. I believe it goes to the original address, Jonno, to make sure that was requested by the real person.

  15. 12sp
    Member
    Posted 4 years ago #

    This sounds completely different. The message came up with all my users and notification was not an issue.

    You could still try what I did and deactivate everything, everywhere. then reactivating them. If that does not work I recommend starting a new post on the forums.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.